powered by Jive Software

0x02 result and no 0x00 from Socks5 proxy

Hello, my native language is spanish but I speak something of english. Only I hope that you understand my problem. For me is very difficult to solve, I guess that.I tried a lot of thing but none resolved the problem. The problem is the next:

I want to transfer a file from A client(client Spark 2.6.3) to B client (my client that I’m developing) or from client B to A client. I have open fire 3.7.1 version.In the case of client B to A client. The Spark client and my client are in the same computer. I do the next under XEP-0096 (SI File transfer), XEP-0065(Socks5 bytestreams) and XEP-0047(In band bytestreams):

1.B->A (my client to Spark client)

<iq type=‘set’ id=‘offer1’ to=‘receiver@domainopenfire/Spark 2.6.3’’>

<file xmlns='http://jabber.org/protocol/si/profile/file-transfer
name=‘test.txt’
size=‘1022’’>

  <desc>This is a test. If this were a real file...</desc>
</file>
<feature xmlns='[http://jabber.org/protocol/feature-neg](http://jabber.org/protocol/feature-neg)'>
  <x xmlns='jabber:x:data' type='form'>
    <field var='stream-method' type='list-single'>
      <option><value>[http://jabber.org/protocol/bytestreams](http://jabber.org/protocol/bytestreams)</value></option>
      <option><value>[http://jabber.org/protocol/ibb](http://jabber.org/protocol/ibb)</value></option>
    </field>
  </x>
</feature>

2.A->B (Spark client to my client)

[http://jabber.org/protocol/bytestreams](http://jabber.org/protocol/bytestreams)
     <value>[http://jabber.org/protocol/ibb](http://jabber.org/protocol/ibb)</value>

    </field>
  </x>
</feature>

3.B->A (my client to Spark client)





4.A->B (Spark client to my client)





And that is the error. I don’t know why that happens.I have tried within firewall and happens the same. Do you have something idea?

With in band bytestreams happens the same. The same error. I searched in the internet but I did not find a lot about this problem and its solution. I have found too that there is problems with Xmppframework. I think that is similar my problem. However I did not find solution. Perhaps I’m doing something wrong. I don’t know

I hope that you can help me.

Now, I will write the same but in spanish.

Yo quiero transferir un archivo de mi cliente a el cliente Spark pero ocurre lo que especifique en los xml que envio y recibo.

Espero que puedan ayudarme. Creo que este problema nose si es un bug o nose la verdad.

Now, I solved something but no all. The problem was I had different id and sid in SI request and Socks5 request. But now, I have other problem. I don’t know as continuing. Later of receiving:

<iq from=receiver@domainopenfire/Spark 2.6.3’
id='hu3vax16’
to=‘myclient@domainopenfire/app’

type='result'>




I open one conexion TCP to 24.24.24.1 and 7777. This is under Xep-0065. But later, really I don’t know as continuing. I know it must be established with a Socks5 connection. I don’t understand as doing that. The protocol says:

CMD = X’01’
ATYP = X’03’
DST.ADDR = SHA1 Hash of: (SID + Requester JID + Target JID)
DST.PORT = 0

I know to calculate sha1. But my question is if I have to do other Tcp conexion with sha1 hostname and port 0? or to send sha1 as data in the Tcp conexion (the conexion of 24.24.24.1 and 7777).

In spanish: Nose como utilizar el sha1 para la conexion de Socks5. Nose si es otra conexion Tcp con el hostname igual al Sha1 y puerto 0.

Thanks very much.

Hello again. I have solved one part but yet I have problems. Now I get 0x02 as result from proxy and I should obtain 0x00 when I send (sid + requester@domain/resource + target@domain/resource. Any idea?

My problem is similar at it: http://community.igniterealtime.org/thread/28006

I don’t understand very well why that happends. Do lack me something more?

My openfire’s version is 3.7.1 and Spark’s version is 2.6.3.

Thanks very much.