powered by Jive Software

1.1.0 Beta 2

MxSan wrote:

I tried to disable the auto reconnect, but couldn’‘t find any option to do so in the admin. I don’'t know what about the underlaying code.

Oh I see what you mean, it’'s not even listed for those, is it. Dooh! GATE-259

I wanted to disable, because I thought it would have stopped an error which I get from MSN ,but didn’'t. Then I saw this was missing for the new transports.

The problem with MSN was already posted before I think (You were disconnected from MSN because your account signed in at another location.).

Yeah, that’‘s GATE-242 kinda. But generally I’'m trying to get some logs to help me figure out what might be causing it. =(

I really want to help you with the logs. However after restarting my client there aren’'t any errors so far :stuck_out_tongue:

As soon as I get something, I will PM you or post it here.

Personally I think it really has to do something with the reconnect feature for MSN. Later today I will enable it again and hopefully it doesn’'t work, so you can make it work.

Edit: Even ICQ seems to work now, I don’'t get the too-many-clients-wait-for-15-minutes-message

Message was edited by: MxSan

HI.

You were right. Finally I managed to delete the user account from his own contact list from Yahoo client, and everything looks ok now.

Thanks for your support.

Seems I was wrong.

Can I sent the debug log to an email address of you? It has over 1.000 lines.

I cleared the logs, started my client en tried to sent a message to someone on MSN.

It has some personal information, so I trust you to treat it right.

Certainly, send your logs to jadestorm@nc.rr.com (or via private message here in the forums)

Sent it.

Just a note: on my roster it looks like MSN is still online. I even got some people looking available. In the admin it shows I am not signed in with MSN

This . . . is very odd. First off, you are being sent an OUT OTH message from MSN. This is MSN’‘s way of telling you "I’‘m logging you out" and OTH means “because you are logged into another location”. However, that message is -supposed- to be followed with a - and then the account that’‘s logged in elsewhere. So… that’‘s odd in itself. Why is it not sending what it’'s supposed to send?

What’‘s doubly odd is that you receive that message, the session is closed inside the JML library, but … the session keeps going? The connection wasn’‘t -really- closed? If you are curious, look through the log you sent me and find OUT OTH. Look at the next line where it says session 13 closed. Then go past all of the unavailables to where it says Login completed?! note that session 13 is still spewing messages. The hell? It’‘s as if MSN told you to go away but was kidding. Clearly something is wrong here but it’‘s not yet clear what. I’'ll keep looking at it. GATE-261

Also note that the reconnection code didn’'t come into play at any point in that log. (it spews out a debug message when it tries)

That sounds really difficult to me.

I figured it didn’'t had anything to do with the reconnect feature. With the first beta it seemed it was solved when disabling it. Guess that was just luck.

Here’'s a quick “latest build” on gateway.jar that includes some cute tweaks to the admin console, a fix for the status issues with Yahoo contacts coming online and not being seen, and moves all of the annoying yahoo input error messages into debug logs. =)

oh, and it also includes fixes for the concurrency issues and such.

Message was edited by: jadestorm
gateway.jar (1085196 Bytes)

I updated to your latest build. But then suddenly ICQ told me I had too many connection attempts and blocks me for 15 minutes. Also I have this in my warning log:

org.jivesoftware.openfire.net.SocketConnection@3c0b655a socket: Socket[addr=/212.227.132.222,port=48009,localport=5269] session: null

2007.06.23 11:59:09 Closing session due to incorrect hostname in stream header. Host: icq.jabber.st-city.net. Connection: org.jivesoftware.openfire.net.SocketConnection@35a631cc socket: Socket[addr=/212.227.132.222,port=48013,localport=5269] session: null

2007.06.23 11:59:09 Closing session due to incorrect hostname in stream header. Host: aim.jabber.st-city.net. Connection: org.jivesoftware.openfire.net.SocketConnection@609f3e95 socket: Socket[addr=/212.227.132.222,port=48014,localport=5269] session: null

2007.06.23 11:59:09 Closing session due to incorrect hostname in stream header. Host: icq.jabber.st-city.net. Connection: org.jivesoftware.openfire.net.SocketConnection@4e3c35fd socket: Socket[addr=/212.227.132.222,port=48021,localport=5269] session: null

I don’‘t know if this is somehow related to each other but I’'m watching the problem and report back if something changes.

Edit:

I have a few ICQ contacts online in my list though ICQ Transport tells me I’'m actually offline :-/. When I then try to logon to the ICQ Transport these contacts go offline again.

Message was edited by: Obi_Wan

That error doesn’‘t sound like it’‘s coming from the gateway plugin. I’‘m wondering if you aren’‘t running into the “typical” problem where things haven’'t cleaned up properly before the new gateway plugin was unpacked. Try removing the gateway.jar file entirely from your plugins directory, wait for the directory named gateway to be automatically removed, then reinstall gateway.jar. See if that does the trick.

I got new news I just tried to relogin to the ICQ Transport. It isn’'t throwing me out any more. So I think maybe there were several connection attempts from my client while the transports were restarting on update and this maybe caused ICQ to be nasty to me.

Btw. The new version looks really good. I can’'t wait for it to be stable :). Good work.

I’'ve just received a message from one of my friends via MSN. When I tried to answer, the server sent me an error message. The debug log contained the following information:

2007.06.25 12:04:24 Received message packet:

After that, I was unable to answer on any messages via MSN. In addition, the MSN Transport sends me an error message on each login. I’'ve already described this issue here . After a restart of the plugin, I could send messages, but I still received the error message after logging in.

Best regards

Sven

Oh I’'ve seen there have been quite a few bug fixes including memory leak fixes. Are you going to give us a new build to test maybe?

Good god =P I just finished that 3 hours ago. Gimme some time to run some tests on it. hehehehehe Yes, I’'ll be posting a build soon.

Ok I’'ll wait ^^

see here - http://www.igniterealtime.org/forum/thread.jspa?threadID=27401&tstart=0

Hi,

I tried 1.1.0 Beta 2 just now and I can see all the gateways on the Openfire Console.

I have enabled YM, MSN & Gtalk gateways and connection test for each of them is successful. YM & MSN connect as well.

However in my ‘‘Spark’’ client I am not seeing any ‘‘icon’’ for Gtalk like the ones I see for MSN & YM. Do I need to add any plugin to Spark also ?

Amod

Hi,

Found that though I can’'t see ‘‘gtalk’’ icon in the Spark client if I add registration from server console I am able to chat with Gtalk contacts/friends

Has anyone configured ‘‘Gtalk’’ in Spark ?

Amod

Spark has no support for GTalk or XMPP or IRC or SIMPLE. Due to the way the support is handled in Spark, it’'ll require a new version to incorporate those transports. I would post the request in the Spark Support forum so that Derek knows there is an interest. =)