powered by Jive Software

1.1.4 Installation Errors

I seem to be having some trouble installating 1.1.4. I’'ve downloaded both the online and offline installs but I encounter the following errors during the installation of either one:

C:\Program Files\Spark\lib\activation.jar

Could not create this file. Shall I try again?

If I say yes I get the error again. If I say no, I get:

C:\Program Files\Spark\lib\base.jar

Could not create this file. Shall I try again?

If I say no to that I get the same error on the following files:

smack.jar

smackx-debug.jar

smackx.jar

spark.jar

\windows\jdic.jar

\windows\tray.dll

logs\error.log

resources\systeminfo.dll

Spark.exe

and a ton of other files…

Any thoughts?

Ariston

More details from error.log

java.io.IOException: Invalid argument

at java.io.WinNTFileSystem.canonicalize0(Native Method)

at java.io.Win32FileSystem.canonicalize(Unknown Source)

at java.io.File.getCanonicalPath(Unknown Source)

at java.io.File.getCanonicalFile(Unknown Source)

at com.install4j.runtime.installer.Common.getRunningProcesses(Unknown Source)

at com.install4j.runtime.installer.Common.checkRunningProcesses(Unknown Source)

at com.install4j.runtime.installer.Installer.install(Unknown Source)

at com.install4j.runtime.installer.frontend.screens.InstallationScreen$1.run(Unkno wn Source)

could not delete C:\Program Files\Spark\lib\activation.jar

could not delete C:\Program Files\Spark\lib\base.jar

could not delete C:\Program Files\Spark\lib\smack.jar

could not delete C:\Program Files\Spark\lib\smackx-debug.jar

could not delete C:\Program Files\Spark\lib\smackx.jar

could not delete C:\Program Files\Spark\lib\spark.jar

could not delete C:\Program Files\Spark\lib\windows\jdic.jar

could not delete C:\Program Files\Spark\lib\windows\tray.dll

could not delete C:\Program Files\Spark\logs\error.log

could not delete C:\Program Files\Spark\resources\systeminfo.dll

could not delete C:\Program Files\Spark\Spark.exe

could not delete C:\Program Files\Spark\jre\bin\awt.dll

Hi Ariston,

are you allowed to create the folder(s) “C:\Program Files\Spark\lib” manually? Maybe you are using a “user” account without permissions to write in “C:\Program Files”. You could even try to install it in “c:\temp”.

LG

Hello!

Does this mean one has to have admin rights to install the new version over the old one? Up until now I thought user rights would be enough.

IF one has to have admin rights how does this then work with the Spark Manager???

No way, that all my users will get admin rights on their pcs just for the fun of easy upgrading of a single application like spark!!!

Pls may we have a serious answer by one of the big boys, thx!

Bye

Starry

Hi Starry,

some “admins” deny write access to “%programfiles%” for users. So its no change for 114 but can explain why one can’'t install it in “%programfiles%”.

The other explanation would be of course that Spark 113 is still running and on Windows it’'s usually hard to replace files which are accessed.

LG

Hey Starry,

I do think that the most probable reason for this error is that you do indeed have a version of spark running. During the upgrade process, such as using Spark Manager, you are asked to exit the application before installation. Let me know if this is indeed the issue, if not, I would like to investigate further.

Cheers,

Derek

Yep that must have been it. I closed out of Spark and re-tried the installation and it completed just fine. I have complete administrative access over my laptop so it wasn’‘t a permissions issue. I wanted to test it out before deploying it to the 100 workstations we have. I’‘m just hoping that Spark Manager won’‘t interfere with the installation if Spark doesn’'t close properly even when prompted.

Thanks for your assistance!

Hi acollander,

You’'re welcome If you could, I love to be updated about how your larger deployment is going. One of the areas we really want to tackle, is the mass deployment of the system and what we can do here at Jive to make your experience as possible. Just let me know.

Cheers,

Derek

Well, I’'ve run into the same problem when trying to use Spark Manager. I had a workstation running 1.1.3, used the “Check for Updates” feature and it did say there was a new version. It said that it needed to close Spark in order for the installation to continue, to which I said Yes.

I proceeded to uninstall the old version, but during the installation of the new version, I ran into the same “Can’'t create file” error. Now this user does not have local admin rights, but I was able to install 1.1.3 into the C:\Spark folder with no trouble. Now trying to install to the same folder yields the errors.

Have you tried to install it in that manner?

Thanks for your assistance! I’‘ve found Wildfire to be one of the best Jabber servers thus far. Although Spark is still a little bit heavy on the memory usage (I have about 29 users online right now and my client is using 42 MB…and I’'m on 1.1.4 after a manual reinstall). Some of our workstations only have 256 MB of RAM, so tacking on a 40 MB application along with IE and Microsoft Outlook the systems can get pretty slow.

I’'ve been using the I-Ball chat auditor to audit the chat logs, although an integrated solution would be more preferable.

Other than those items, the combination of Wildfire and Spark have helped a couple of our departments save time during production!

Ariston