powered by Jive Software

1 domain across 2 locations but 2 openfire Servers


I have a single windows domain across 2 locations but i want to create 1 openfire server in each location. So, can someone guide me on how to setup the srv records for the 2 servers, its confusing because the domain is the same so the dns records will be the same in both locations but there will be a openfire server in each location.

If my question needs more clarification please let me know.

Thanks in advance.

What do you want to achieve? It seems that in that case you are going to have a cluster (same database, two servers). Or do you want to import only a part of users on each server, but then you probably want them to be able to talk to each other? This sounds impractical.


Actually this type of setup was up and running before with the older version of Openfire, but the latest version is requiring a correct srv record in dns which i did not do before.

Before it was setup that each location had its own openfire server with its own database and users. And the users from each location were able to talk to the users in the other location using server to server connection. Both servers were joined through a VPN connection so essentially they are on the same network because the domain is the same.

So now when i have to add the srv records in DNS because the DNS server is the same for both Openfire servers then what is the best method of creating the DNS SRV records?

Also if there are any better ideas on how to improve our setup this up then i am open to those also.

Well, i would understand such setup if users were to be isolated (one location from another). Now you have to deal with s2s setup for them to be able to talk to each other. Of course, when one location goes down, then the other part still can talk among each other. But that would be solved by some failover (cluster for database and cluster for Openfire). Clustering could be more complex though.

Anyway. Do you have any problems with Openfire or s2s connection between servers? A warning about SRV records on admin page is only an informational thing. It might be working ok depending on your setup. It just informs you that you may make it more proper by adding SRV records.

Though in your case i wonder if it is even possible to have such records. Because SRV record is to point a client which is looking for any xmpp server on your domain to a particular server/machine. In your case there are two servers in your domain, so SRV record won’t help\work i think. SRV record’s format is like

xmpp-client.tcp.example.com IN SRV 0 0 5222 jabber.example.com.

This points a querying client (looking for a xmpp server on example.com) to jabber.example.com server. So, if you would have two SRV records pointing to two different servers, i think in some cases clients would be trying to connect to a wrong server. Also, in this example a client is trying to connect to a domain, not to a particular server or IP address. SRV records are only useful in such case.

If it doesn’t work now, then what was your setup before? What were servers’ names, how were users logging into their clients (domain/server part) on both locations? I assume they were using different server names/IP addresses .

Hey Wroot,

the server names were different before for each location.

The problem i have right now is that after upgrading to the latest version of Openfire, the spark clients can’t login to the server. There have been no other changes other than upgrading openfire and the spark clients to the latest version.

And after upgrading i saw the srv records message in the admin panel. I didnt get that message with the older version of Openfire that i was using. So i assumed that the srv message is the reason why the spark clients cant login into the server.

So the only problem that i have is that the spark clients cant login. I searched on the forums about the changing some options in the spark application but the problem is that on my test laptop the spark application doesnt even show the advanced option. there is only 1 button on it saying login. I am using windows 10.

So if there is something else that i am missing or should be doing please let me know. Other than the upgrades everything was working great.

Thanks for all the help

Well, updating Spark to the latest version was big update (if updating from 2.7 to 2.8). A lot have changed between these versions. You can test it by installing 2.7.7 again (just change the download url, if you don’t have its setup saved). If 2.7.7 works fine, then it will be Spark issue. Most probably related to certificates, which can be solved by enabling options in the Advanced menu.

Advanced menu is not shown for you because you have old version of Client Control plugin installed in Openfire. Update it and all the menus should show up again.