powered by Jive Software

2.3.8 Offline messages encoding

After upgrade to 2.3.8 messages sending to offline users come with wrong encoding: ??? ??? ???

Know this issue or my wrong installation ?

[SOLVED]

Use line to /opt/openfire/conf/openfire.xml

was:

jdbc:mysql://localhost:3306/openfired?rewriteBatchedStatements=true</ serverURL>

now:

jdbc:mysql://localhost:3306/openfired?useUnicode=true&characterEncoding=UTF- 8& characterSetResults=UTF-8

Then restart MySQL server and Openfired server.

And groups sharing bug fix too for me.

Not enabling rewriteBatchStatements has a huge impact on pubsub performance.

What is pubsub ?

With “rewriteBatchedStatements” and "useunicode"openfire not starting. Then i disable it.

If you don’t know what it is, then you probably aren’t using it. It is an extension in XMPP to support publish/subscribe message dissemination. PEP (Personal Eventing Protocol) is a subset of this.

This is irrelevant though, as the **rewriteBatchStatements **has nothing to do with encoding. Your solution actually removes something that is needed and added something else that was apparently needed as well. My point is that you should have added to the existing declaration instead of removing the rewrite parameter.

Thanks for explanation

At first, i try to add string “use encoding” to existing command, but openfired not started after that. Web-admin started, but continous installation mode.

jdbc:mysql://localhost:3306/openfired?rewriteBatchedStatements=true?u seUnicode=true&characterEncoding=UTF- 8& characterSetResults=UTF-8</ serverURL>

Whith this comnnad openfire cannot start.