powered by Jive Software

3.8.1 still using old Java

Just installed 3.8.1 on windows server 2008 this morning but the admin console still shows 1.6.0_18 Sun Microsystems Inc. – Java HotSpot™ Client VM. According to the release notes this was to be on Java 7 now or at least the most updated Java 6.

http://www.igniterealtime.org/downloads/index.jsp

http://www.igniterealtime.org/downloads/index.jspopenfire_3_8_1.zip Does not include Java JRE

openfire_3_8_1.exe Includes Java JRE (recommended)

which did you get?

The .exe with the JRE. And when I install it I see it put the files in the JRE directory but the status still shows the wrong version. Also if I check the file version java.exe it still says V6_18 as well

I will ask Daryl about this (OF-612).

You can of course install the latest Java and delete the jre folder in the Openfire folder. Then it will use the latest Java.

I thought about doing that but I thought I would report the issue as well.

Is Java 6 or 7 the recommended install now?

I think even 3.7.1 was supporting java 7 already. I’ve been using latest java for year or longer maybe. No issues.