powered by Jive Software

3.91 to 4.4.1 all group chats missing

I didn’t do this on a live server, i test everything first. I just took over being the admin of a openfire server with 2000 users and 100+ group chat rooms. I did an upgrade from 3.9.1 to 4.4.1 and now all the group chats are missing from the web interface. The are in the DB.

So far it’s the only issue i’ve noticed but this is a game stopper for this if I can’t fix it.

I did try doing the upgrade paths from 3.9.1 but alot of the versions crashed with java heap errors but 4.4.1 seems stable. Likely the built in x64 java.

Greetings, I am glad you are trying this in a test environment. Please check the following things.

  1. For any messages logged during the first startup of 4.4.1 to see if any of the database upgrade scripts failed.
  2. On the admin console, do the MUC rooms show up along with the conference service too?
  3. any errors logged when you join a chatroom?

Have you tried to upgrade gradually? Install the latest version of 3.9. Then install the latest version of 4.0, etc.

download > https://github.com/igniterealtime/Openfire/releases
guide > http://download.igniterealtime.org/openfire/docs/latest/documentation/upgrade-guide.html

This I tried but I get nothing but Java Heap crashes for anything before the embedded X64 Java versions. I am moving from Linux 3.9.1 to WIndows Server 2012 4.4.1

  1. Each time Missing database schema for openfire. Attempting to install…
  2. Conference Service yes, Rooms no the list is blank
  3. If I join a room it creates it like a new room.

So we need to debug more what is happening with the first item you list. What is your backend database and are you able to look at its logs to see if openfire is generating some issue?

Would it make sense to deploy a new openfire DB and then move my data over to it from the old one?

Depends on how much data you want to save during the transition. The upgrade path should work though, we just need to find the logs showing what error you are hitting. If you want, you can email me your logs/ folder contents and I can review it. akrherz@iastate.edu

I sent you an email. Thanks.

I got it, can you directly access your database and see if the ofVersion table exists? If so, can you select all entries from it?

clientcontrol 0
fastpath 0
monitoring 3
sip 2
user-status 1

Thats all that is in it.

Thanks, so openfire is missing in that list. version 3.9.1 should have schema 21. So can you try adding this

INSERT into ofVersion(name, version) VALUES ('openfire', 21);

and then restart openfire 4.4.2 to see what happens?

Didn’t seem to work. Emailed you logs again.

I am going to try fresh new DB, and then copy just my data over see what happens after that.

Soo Interesting turn of events. I got the server upto 4.4.2 and the chatrooms stayed around. It wasn’t until I restored the ofmuconversationlog table did they all go missing again.

So if I add a new room, restart the server. The rooms go missing from the web interface BUT are all in the DB still. So something odd is going on.

xmpp.muc.unload.empty_days 999 doesn’t help either.