powered by Jive Software

A few questions: Red5 SparkWeb configuration / Fastpath

Hi everyone,

I have a difficulty configuring red5’s sparkweb. It does not connect to my openfire server (though the standard sparkweb works fine). When I enter my userame, and click on login, the login button just becomes gray and nothing happens.

I am using red5 0.1.10 plugin and openfire 3.6.3.

Connection config of sparkweb:

function jive_sparkweb_getConfig()
{

    var username = getPageParameter('username', '');
    var password = getPageParameter('password', '');
    var autologin = getPageParameter('autologin', 'false');
    var webapp = getPageParameter('webapp', 'red5');
    var conn = getPageParameter('conn', 'socket');            // socket, http or rtmp (using xmppurl below)
    var tls = getPageParameter('tls', 'true');                // socket, use TLS or not

    return {

        httpLabel: "Ignite",
        httpURL: "[http://www.igniterealtime.org](http://www.igniterealtime.org)",
        username: username,
        password: password,
        server: "regmac04.uwaterloo.ca",
        port: conn == "socket" ? 5222 : window.location.port,
        red5url: "rtmp:/sip",
        xmppurl: "rtmpt::8000/xmpp",
        webapp: webapp,
        connectionType: conn,
        connectionTLS: tls,
        policyFileURL: "xmlsocket://" + window.location.hostname + ":5222",
        webcamAvatar: "false",
        visualPresence: 120,
        historyChats: 2,
        autologin: "false"
    };
}

I have port 7070 enabled in openfire… I tried to change the port to 7070 in the config for sparkweb (instead of 5222, as above), but it didn’t work.

Please help me to figure out what could be wrong with my connection settings. I know there are simillar posts on the forum, but they did not really help me to figure out what should I do…

Any help would be appreciated! Thanks in advance!

Also, please tell me if red5’s sparkweb will also allow me to work with fastpath through the web browser? I tried one red5 sparkweb client available on the internet to connect to my openfire server, but unfortunately it didn’t really work with fastpath…

Haven’t set up Red5 ever, but looking at google, I found these docs.

HTH

http://www.igniterealtime.org/community/docs/DOC-1518

http://www.igniterealtime.org/community/docs/DOC-1520

Thanks for your reply!

Actually, I have red5 up and running (as I think… i can access the test page), I just need to configure sparkweb to work with my openfire server.

I desperately need some sort of a live help system based on xmpp, but apparently there is only fastpath and alkeni (which is not open source and outdated)…

So my fastpath works fine, I can access it from spark. I just need to be able to use it from sparkweb.

Are there any other live support programs based on jabber protocol?

Thanks!

I am having the exact same problem using the same version of red5 and openfire. Sparkweb works, Spark works, but I just can’t log in using red5. I get the same greyed out login icon. I really need tls support, and from what I have read red5 is the only way to bring this to spark web correct?

This has already been discussed on a previous thread.

Openfire 3.6.3 does not support Adobe Flash cross domain policy for TLS connections. It excludes port 5223 in its response. I have a patch which fixes this at http://red5.4ng.net/openfire.jar

Sorry about the repeat . I read the other thread, and I was just confused because I thought that it had been added to the last release of Openfire. My bad.

I will give this a shot.

Hi All,

I am using openfire 3.6.3 and red5 0.1.02 plugin on Windows environment(red5plug from http://www.igniterealtime.org/community/blogs/ignite/2007/08/30/desktop-screen-s haring-with-openfire). I am able to load the red5 and sparkweb successfully at http://localhost:7070/red5/sparkweb/index.html. But, onclick of the fastpath tab, I am not able to view any fastpath related content in Sparkweb window.

Is there any configuration that needs to be done to run the fastpath from Sparkweb. Can you please let me know if there is anything that I am missing.

Thanks,

Subbarao

Try latest version

http://red5.4ng.net/red5-0.1.11.zip

Hi Dele,

Thnaks for giving reply …

I am using letest red5 plug in what u gave that link (http://red5.4ng.net/red5-0.1.11.zip) but currenly I am able to load the red5 and sparkweb successfully in this version instated of Sparkweb tab i got SupportTeams.

Thanks,

Subbarao

Hi Subbarao

Have you fixed this problem then, as I was also getting the same issue, everthing seems to load fine but the Fastpath Tab did not show anything ?

Paul

Hi All

I am using latest red5-0.1.11.zip .it works fine in red5 and Sparkweb also but only difference is in previous red5 version i am not able to view any fastpathcontent and fastpath tab In letest version [http://red5.4ng.net/red5-0.1.11.zip] i am able to view content but instated of Fastpath tab i got SupportTeams tab.

Thanks

Rajarao…

Hi

Do you still have the patch for this, as the link is down(http://red5.4ng.net/openfire.jar) ?

Paul

Hi

Now link is up u can download that jar…