powered by Jive Software

About the red5phone authentication

Sorry about my English is not too good…

first…Thanks the amaze red5phone…

It’s work very well…

but I have a question about red5phone with Asterisk authentication…

I change Asterisk PBX ,and I got 401 message from my Asterisk PBX with my red5phone…

I think it’s “Challenge”(I got WWW-Authenticate info) from Asterisk PBX, So how do I modify the code to register with WWW-Authenticate…

My red5plugin version is 1.0.6…

Thanks for help…

can you provide more information on what changed in your AsteriskPBX. I have only tested with 1.0, 1.2 and 1.4. I use this for my SIP device

[1002]
type=friend
context=default
username=1002
secret=1002
host=dynamic
qualify=no
canreinvite=yes

Thanks Dele…

I use AsteriskWin32 0.66b(Asterisk 1.2.26.2) to test red5phone.

It’s work very well.

Then I try change Asterisk(1.4.19.2) on Linux (CentOS 5.2).

It’s unregister.

I use same sip.conf.

[1000]
type=friend
username=1000
secret=1000
host=dynamic
context=default
nat=yes
transfer=yes

Is it difference Aserisk version problem?

I have change Asterisk because the AsteriskWin32 to disturb asao2ulaw work(same pc).

Thanks…
192.168.1.21.5090_messages.log (2611 Bytes)

hello…

I have to keep try about this question…

I use callme to try register Asterisk.

I got 407 msg from Asterisk.

The 407 msg include Proxy-Authenticate.

so I think same issues with red5phone need to response Asterisk challenge(Have anyone know how to config about this in Asterisk?thanks!).

I will try to modify this problem.

Maybe this problem only for me.

Thanks!!

update my test…

I remove sercet in Asterisk, like…

[1000]
type=friend
username=1000
-secret=1000
host=dynamic
context=default
nat=yes
transfer=yes

It’s working now…

but, why?

I need use secret…

But Asterisk still respone 401 unauthorized…

I will keep try…

I find the answer about this problem…

Let us check the 401 packet.

no working:

SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.1.21:5061;branch=z9hG4bK67675;received=192.168.1.200;rport=38501
From: “1000” sip:1000@192.168.1.200;tag=z9hG4bK92260199
To: “1000” sip:1000@192.168.1.200;tag=as01d93605
Call-ID: 486825253917@192.168.1.21
CSeq: 1 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
WWW-Authenticate: Digest algorithm=MD5, realm=“asterisk”, nonce="6a90481e"
Content-Length: 0

working:

SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 192.168.1.21:5060;branch=z9hG4bK88201;received=192.168.1.200;rport=38500
From: “10001” sip:10001@192.168.1.200;tag=z9hG4bK02144746
To: “10001” sip:10001@192.168.1.200;tag=as058441f8
Call-ID: 828377853263@192.168.1.21
CSeq: 1 REGISTER
User-Agent: Asterisk PBX
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces
WWW-Authenticate: Digest algorithm=MD5, realm=“192.168.1.200”, nonce="3020abcc"
Content-Length: 0

I just add one item in the sip.conf

[general]

realm=192.168.1.200 ;your Asterisk IP

So, It’s working now…

But I have another question now, Why?

In the normal case, I don’t need change that(like this http://www-rocq.inria.fr/who/Philippe.Sultan/Asterisk/asterisk_sip_external_auth entication.html)

Can somebody tell me what’s happening?

Thanks