powered by Jive Software

Action Dial does not appear

Action-> dial does not appear on Spark.

Asterisk-IM integration worked. No errors in logs. I see that Name mappings also worked.

I see notifications when user is on the phone and off the phone…, but Actions -> Dial button does not work. Any ideas.

PS: my SIP usernames are digits, but my Jive users are LDAP users with normal alphanumeric usernames. Does that matter.

Regards,

KIRAN

I have the same problem. Asterisk is configured and up and running and phone presence is working (on the phone, …). The only error in my log is or what may be an error is : OnPhoneTask: Could not find device/jid mapping for device SIP/172.2x.xxx.xxx returning

I turned on Debugging and this is the error message I see:

No userID found - phone-users.jsp

I’'m not sure what that means. I re-created the User mappings and still same error.

i’'m using MYSQL and as seen below, there is a userID.

mysql> select * from phoneUser;

*----


*----


userID

username

*----


*----


6

kkumar

*----


*----


1 row in set (0.00 sec)

mysql> select * from phoneDevice;

*----


*–


+


+


+


+


+–


deviceID

device

extension

callerId

isPrimary

isMonitored

userID

*----


*–


+


+


+


+


+–


8

SIP/3035

3035

Kiran Vangaveti

1

0

6

*----


*–


+


+


+


+


+–


1 row in set (0.00 sec)

Any help is greatly appreciated. This is a wonderful feature and I wish I could get this to work.

Regards

KIRAN

kkumar,

I have just granted you the attach permission to this forum. Can you upload your sip.conf (minus passwords). I need it to try and recreate your environment.

Also which version of messenger, asterisk-im, spark are you using.

thanks,

Andrew

I’'m using spark 1.0.1, jive messenger 2.3.1 and Asterisk 1.2 and Asterisk-IM 1.0

Thank you

Regards

KIRAN

Message was edited by:

kkumar
sip.conf (1995 Bytes)