Active directory trouble

Hi i am trying to connect openfire to my active directory (Windows 2008 Server std PT version)

on the 1st STEP

i have this:

Server type: Active Directory

Host: myhost.pt

Port: 389

BaseDN: ou=Users;dc=myhost,dc=pt.

Administrator DC: myhost\Administrador

password: mypass

everything ok it tests OK

in the next SETP

when i try to test i get this error:

No users were found using the specified configuration. Try changing the base DN, user filter or username field.

i’ve chnged the BaseDN to: cn=Users;dc=myhost,dc=pt.

and i get the same error…

any sugestions ? i am new to active directory… so i am lost…

I had a similar issue. I set the port number to 636 on the LDAP setup page and in advanced set everything to “yes” except enable debug, set that to “no”.

make your base DN the root of your AD tree, then use search filters to filter out everything you don’t want to show.

so base dn would be something like DC=domain,DC=local

did not work…

i am open to more sugestions…

try changing your administrator username from domain\administrator to administrato@domain.local

Change this:

BaseDN: ou=Users;dc=myhost,dc=pt

To this:

BaseDN: OU=Users**,DC**=myhost,DC=pt

Case sensitivity fixed a similar issue for me. ou does not always = OU.

tested… did not worked out…

In the text example you provided here, you are using a semicolon (:wink: as well as commas (,). Is this what you really have in your config? Try getting rid of the semicolon; Make it a comma.

It took me a few days to get this syntax part right on Server 2008. A lot of trial and error.