AD LDAP Filter only partly working?

Hi all,

I had a perfectly working 2.6.2 install going, but, wanting the latest, greatest release, felt it was time to install 3.01. Now I have a problem that when I put my AD info into the LDAP settings only 7 of my 45 users show up. I’‘ve tried changing the objectClass from person to user to organizationalPerson, to no avail. My setup is that users that are in the JabberAccess group are granted access to the IM server. I can’‘t see anything obviously unique about the 7 users that are showing up. My username scheme is f.lastname so everyone’‘s username is formatted the same. I’‘ve tried using a different group to filter on, but that didn’'t work either.

Anyone with any ideas would be greatly appreciated.



Here’'s my search filter:

        (memberOf=CN=WF,OU=Emp Groups,OU=Employees,DC=ADCI,DC=LOCAL)

Message was edited by: gedron

I can’'t see your filter settings… Bu here is my search filter settings that are working great with 3.0.1


<searchFilter> <![CDATA[




(memberOf=CN=All Staff,CN=Users,DC=domain,DC=com,DC=au)




]]> </searchFilter>

Never had LDAP setup on previous WF versions, so not sure if the format has changed at all…


Have you tried using an LDAP browser such as the free one found here

And checked that all users that you want included in the filter have the correct settings