AD LDAP headache. Username Field Error

Can someone please explain where I can find the damnedable sAMAccountName on my server? I tried entering sAMAccountName into the Username Field and it gives me an error:

Status: Error

No users were found using the specified configuration. Try changing the base DN, user filter or username field.

How do I know what I need to put in that field? I’ve tried domain\sAMAccountName and all sorts of variations thereof.

Please help!


I had this same problem. I figured out that when I entered my domains info and clicked the test button that the browser would delete the info. So as I saved and continued there was nothing in the fields for it to even attempt to work.

It seems that this is a problem with your base DN configuration. You need to go back to that screen and test your base DN configuration value.

See the Openfire LDAP guide here for details: de.html

I just recently did a deployment where I was fidgeting with this a bit as the users are under an OU and not a CN. So instead of cn=Users,dc=domain,dc=com, I had to use ou=Doman Users,ou=Admins,dc=domain,dc=com.

Make sure you test the base DN strong and be aware that your users may be under OUs and not CNs.