powered by Jive Software

AD LDAP integration fixed?

Has anyone figured out or squashed the roster problems with Active Directory and LDAP groups? The problem where no groups or users show up in the clients rosters…

Poppa

I’'m having exactly the same problem using 2.3.0 beta 1.

Using LDAP connection to MS AD. Still using system only as testenvironment. Looking forward to a new build.

Something is wrong when LDAP groups are initially loaded. After changing groupsettings to “don’'t show” and back to “show in contacts list for everyone”, the group is showed correctly in the client. Using the pandion client, everything shows up instantly! Great stuff.

I’'ve seen this workaround in another post, seems to work for me too.

I have tried this work around in every version since 2.2.0 and it has not worked for me. We use Psi. But your right, something is broken in LDAP group support.

Poppa

You’'re right. I lost my groups again this morning (without restart actually, guess the server has been idle for too long?).

I checked he debug log and found this:

2005.10.17 08:38:06 Starting LDAP search…

2005.10.17 08:38:06 Using groupSearchFilter: (&(member=CN=xxx,OU=xxx,OU=xxx,DC=xxx,DC=nl)(objectClass=group)(|(sAMAccountNam e=BB Oosterhout)(sAMAccountName=BB Tilburg)(sAMAccountName=BB Breda)))

2005.10.17 08:38:06 … search finished

2005.10.17 08:38:06 Starting to populate groups with users.

Looking at the sequence of commands performed by the server, this is supposed to be the query for finding the roster (using ldap groups of course) right after logging on. In my groupSearchFilter, I have specifically entered the groupnames that are needed in JM, but JM also adds the first “(member=CN=xxx,OU=…)”. My best guess is, that the filter is no longer valid with this addition, so it cannot find any groups nor users. Then again, I’'m not the expert on ldap searchfilters.

Any clues? Thanks for any help in advance.

I’‘m experiencing a similar problem though we do not use Active Directory (we’‘re using Sun’‘s LDAP server). In our case only a couple of individuals (I’‘m one of them) are no longer seeing LDAP group and roster information in thier Client (Gaim). Also, using the Smack API I’'ve confirmed that Jive Messenger is not returning a roster for my account.

Did some checking again using Pandion and Exodus. It’‘s true: without restarting the server, I’‘ve lost my LDAP groups in both clients. I have upgraded 2.3.0 beta1 to beta 2 using yesterdays nightly binary build. It doesn’'t seem to solve the problem. Is there some kind of caching mechanism in place, that takes care of providing the ldap groups to users, when logging in? If I log in regularly (every hour or so), all groups are shown perfectly.

When I lose the groups, I have to reset group settings according to previous post. Then ldap groups show instantly for users that are logged in at that time. When logging in with another account, I still don’‘t get ldap groups. Am I correct when saying that the groups are supposed to be “pushed” to the client by the server on login? That doesn’‘t seem to happen after a night of inactivity on server. Still can’‘t figure it out. I’'m using Windows 2003 AD as ldap backend. My JM (+MySQL 5.0.13rc) is running on FC4 on an older dual proc Compaq Proliant with 1GB of memory.

Is there someone who has a working JM config with Active Directory ldap groups? Please share it with us then!

I have an AD group and for 2 users the shared AD group just stopped showing up and for evenryone else they were marked offline.

The way I fixed it was to go into the mysql table called jiveRoster and kinda hunted and pecked. What I noticed was that the two individuals who were not showing the AD group had some funky sub/ask/recv number and odd things in jid and Nick. I set jid, sub, ask, recv, Nick to null, 0, -1, -1, null respectively and lo and behold the lists were back for these users.

Hope this helps…