Admin Account can't login into OpenFire Interface!

Hello guys!!!

I have a problem when I try to login with the admin account into the OpenFire interface (http://Server:9090)… See the attached image…

The funny thing is that I can login using the admin account into the system using the Spark client…

The Database engine is: MySQL v5.045…

I have full access to the OpenFire database…

Thank you very much for your help!!!

Go to the ofuser table and look for the admin username and check the password there. It might be encrypted, so i suggest u do an update on the usertable for the admin username and remove that password and add a password to the plain password column.


when you install openfire, for first time admin can login, after login we should give the admin rights to that user.

then only after next login you can log on to the admin console.

otherwise the same erroe will be thrown

Hi guys!!!

Thank you for your help…

I was able to resolve this problem just by restoring the backup (only the ofProperty table)!!!

Thank you!!!


I’m having the same problem. Why the password doesn’t work?

I’m using PostgreSQL.

I tried:

  • put encryptedpassword = null and plainpassword = ‘123’

  • change encryptedpassword = md5(‘123’)

But the none of them worked.

Hi at all,

i have this problem too, but i use the embedded db…

At end of process setup open web login page, insert user “admin” and password i type at end of setup, but i recive error login message…

I try to re-run setup, at end request “old admin password” and “new”; control’s old password it’s ok… but login’s page in web administration not work !!!

Someone can help us???

Shut down openfire and the db and restart both.

Thank you for replay

For restart openfire services simply go to /etc/init.d/ and from shell lunch “sudo ./openfire restart”, but for embedded db how i can shutdown and restart?

This is not the problem because I rebooted the OS and it still doesn’t work.

Here is how are the values in the ofuser table.

select * from ofuser;

username | plainpassword | encryptedpassword | name | email | creationdate | modificationdate
----------±--------------±------------------±--------------±---------------- --------±----------------±-----------------
admin | 123 | 123 | Administrator | | 001266957619887 | 0
(1 row)

I tried:

username -> admin

password -> 123

But it didn’t work. I even tried this .html#postgres, but I think it’s not necessary.

Please help.

Please start your own thread. This thread is marked as answer. Plus you cannot award points to people if they help.

are people worried about points …?

Hi Matec!

It’s now working with me.

Try the following:

stop openfire: sudo /etc/init.d/openfire stop

set setup to false: false

start openfire: sudo /etc/init.d/openfire start

go to http//localhost:9090 to make the setup

go to the login page. try to login -> it will show the same error (incorrect username …), that’s ok

stop openfire: sudo /etc/init.d/openfire stop

start openfire: sudo /etc/init.d/openfire start

go to http//localhost:9090 it will redirect you to the login page.


let me know how it works for you.

I love you !!! Really !!! I can’t belive… finally access successfully …

If you will go to italy you have a free beer by me!!!

Procedure in my environment:

  1. stop service openfire
  2. modify tag setup in openfire.xml
  3. reboot system
  4. re-run setup, but skipdb configuration and admin setting (e-mail and password)
  5. reboot
  6. login works well (with my password type in first installation setup)

now hard work to configure… thanks at all ! Bye!!

I experienced the same thing just today. Unpacked the tar.gz file for openfire 3.6.4 and replaced the /opt/openfire directory with the new one. Followed the instructions on guide.html. After that, I got a permission denied message- “Starting openfire: sh: /opt/openfire/logs/nohup.out: Permission denied” when i tried to restart openfire by /etc/init.d/openfire start. “service openfire reload” gave the same result. What did i do wrong pls.

just discovered i can only access the openfire web gui when i run /opt/openfire/bin/ and get the output Admin console listening at

Could precise that information. Where do I find the table, because I wasn’t able to connect to mysql and had to take the internal database.

I just cleared “storedKey” , “serverKey” , “salt” , “encryptedPassword” for admin user in ofUser table.
Then i entered to plainPassword ‘123’, then logged in admin console with 123 password and reset password for admin on console, its created new entries for all of “storedKey” , “serverKey” , “salt” , “encryptedPassword” values and working well now. (v.4.1.6)