powered by Jive Software

Admin account login issues

i’m lost. Whenever i attempt to login, i’m greeted by an error of a wrong password/username combinations. Problem is i know i’m entering the correct combination because i checked my keychain matched with what i was entering. Even worse, no matter whether i completely wipe out and re-install Openfire 3.6.3 or even 3.5.1 and reset my browser, i’m never able to go back to initial account setup–it always asks for the username and password it won’t accept. This only began after i changed the settings for the local host. What am i doing wrong?

What settings have you changed?

i changed my .local

.local means nothing to me. What specifically did you cahnge in the server? Have you tried the default admin account (username admin, password admin)? Have you tried rerunning the openfire config by editing the openfire.xml setup tag to read false.

sorry if it means nothing to you, but it’s all i changed then the next time i tried logging in nothing worked…not the user i created or the default admin. I know this is something wrong on my end, but i can’t seem to see what–i’ve told you everything. Is there some way to delete my account so i can re-do the initial setup?

I should say .local means too many things. we need to know what you mean by you changed .local. When you say that what specifically did you change. What setting where? And did you try to rerun the config as I instructed?

.local as in my domain…which i’m pretty sure is still way too vague–i’m a huge novice with networking (i hate it). I followed this guide:

specifically: step 2 Configure Options

“…For server settings, set your “Domain” to be “localhost”…”

lemme work with the XML idea, thanks.

EDIT

can’t locate .xml

is it a problem if i run OS X? All i’ve got are the plist, pkg and preference pane

Have you checked in this path: /usr/local/openfire

not finding anything in that path…

I am also having the same problem. What happened was the domain name was changed from Domain: localhost to Domain: company.domain.com. What is needed to access the admin section via port 9090 once again?

Thanks,

Roger

I tried changing the /etc/openfire/openfire.xml file and kept getting: “Warning chaning a read-only file” and “Can’t open file for writing”.

What do I need to edit this file? I tried chmod but “Operation not permitted”.

Your help is appreciated.

Look in the openfire database (I use MySQL), table ofProperty, following rows:

Brq549rq459

and

you need to take ownership of the file or enable root on the mac and login that way. you can generally take ownership via the finder using get info. careful with this it could affect openfire running if the file does not have the right permissions.