Admin Console asking for setup info again

I’'ve been having problems trying to get Custom Database Integration working using a MySQL database.

So this morning, I decided to wipe the database tables, reload the default xml file, and start over.

So I ran the setup wizard and checked that wildfire was working, which is was.

I edited the wildfire.xml file and added the details regarding database integration as follows (note this is not my entire xml file before anyone says I’'m missing the <jive> opening tag!):


<className>org.jivesoftware.database.DefaultConnectionProvider</classNa me>


















<jdbcConnString>jdbc:mysql://localhost/osdgndb?user=osgndba&password=***** ******</jbcConnString>




<className>org.jivesoftware.wildfire.auth.JDBCAuthProvider</className&g t;



<className>org.jivesoftware.wildfire.user.JDBCUserProvider</className&g t;




<passwordSQL>SELECT password FROM osdate_user WHERE username=?</passwordSQL>




<loadUserSQL>SELECT firstname, email FROM osdate_user WHERE username=?</loadUserSQL>

<userCountSQL>SELECT COUNT(*) FROM osdate_user</userCountSQL>

<allUsersSQL>SELECT username FROM osdate_user</allUsersSQL>

<searchSQL>SELECT username FROM osdate_user WHERE</searchSQL>






Have restarted the wildfire server, but now when I go to the admin console, I am being asked to set-up the database again. Is this normal, should I proceed with the setup again… or are the modifications to the XML file causing the system to think it’'s in new setup mode?


Ignore the above regarding set-up… I’'d mis-spelt one of the closing tags.

Still can’'t log into admin console though… hmmm!

IMHO, one shouldn’'t be referring to the old threads that uses jdbcProvider.jdbcDriver.className and jdbcProvider.jdbcConnString. The correct form starting from version 3.0.1 (but not the early release) is jdbcProvider.driver and jdbcProvider.connectionString respectively.

This message mentioned about the JM-786 that corrected the property name bugs in JDBCAuthProvider and JDBCUserProvider. The first item description in the unsolved JM-787 is unnecessary and confusing.

Your config:

BTW, you have several threads opened with similar problem. You should continue with the same thread until your problem is solved.

Message was edited by: aznidin