powered by Jive Software

Admin console does not access through another computer on the local network

Hello guys, I use openfire server version 4.5.4 and I can access the Admin Console with only the server (localhost:9090), when I try to access through another computer on the same network, the URL does not load (nameserver:9090). I already disabled antivirus, firewall, changed the default ports and was not successful. Thank you for your support!
note: In some of the previous versions, this access was normal.

I believe that Openfire can be configured to bind to a specific interface, but that’s rarely used. I do suspect that the reason for your problem lies outside of Openfire - some kind of network setting or issue with resolving to the correct host.

I have other web pages that work perfectly, just Openfire that I can’t access from another computer on the network. Strange that on the server, I access normally. Are there any configurations that, for security reasons, block access if it is not accessed by the server?

I can’t think of anything, sorry.

Not strange at all, connecting on localhost is not going through the network, no routing/DNS happens in this case. Are you able to contact it using server’s IP? What error do you get in the browser? Can you telnet from remote computer to that hostname/IP on 9090 port?

After several tests, I went ahead with something: When the Openfire service is active, I can’t access the web console through another computer on the network, however, when I stop the service and start with the OpenfireServer application, it displays the information:
Administration Console listening at: http: // servername: 9090
And ready, it works again!
For what reason with the activated service does not allow this access? Thank you.

Do you have both service and launcher (yellow bulb) working at the same time? Then they would be conflicting.

If not, then i would suspect a firewall issue. When you first ran it with the launcher maybe firewall popup came up and you allowed it. This is not happening for the service and you need to add a manual incoming rule for TCP 9090 port. Although you mentioned you have tried disabling firewall.

Another crazy thought is that maybe you have two different installations. When you connect remotely with launcher running and on localhost when service is running, is it the same server based on settings and users?