powered by Jive Software

Admin console unavailable after 3.2 upgrade

Hi all,

I just upgraded to 3.2

My spark clients are connection just fine. but I can’'t see to get to the admin page.

I see in the log stdoutt.log

Wildfire 3.2.0

Admin console listening at http://domain.tld:9090

I believe I had set the server name to the domain.tdl so that the users IDs would match their email addresses. When I access http://host.sub.domain2.tdl:9090 (which is the FQDN of the server) I get a 503 error

SERVICE_UNAVAILABLE

I searched through the conf directory but the domain.tdl is not in any of the files.

Is this setting in the DB? BTW I’'m using the embedded db and running on Suse enterprise 9 with the rpm wildfire install.

what ist the result of

lsof -i :9090

COMMAND PID USER FD TYPE DEVICE SIZE NODE NAME

java 20025 root 69u IPv6 41181324 TCP *:websm (LISTEN)

I’‘m having the exact same problem since I upgraded from 3.0 to 3.2, the admin console responds with a 503 on both 9090 and 9091… The only thing that changed that might have an impact was I recently enabled IPv6 on this server. Though normal xmpp clients can still connect to server and I would assume any bug regarding IPv6 would be there as well but it’'s not…

–Chad

I’‘ve contacted Jive presales support since I’'m interested in getting the enterprise plugin.

When they get me a resolution I’'ll post it here.

Glad to know I’'m not the only one (I thought I screwed it up).

chrisj

Bump.

Same problem here. I can’‘t connect via 9090 or 9091 to admin console. netstat not showing anything listening on either port. Server rebooted (because I’'m running M$ W2K3 SP1) and no change. Spark clients can connect.

Christian

Did anyone try to go to the plugins directory and delete all of your plugins? Delete all contents in the plugins folder except the “admin” directory. Please be sure to post if it works.

Looks like old plugins were the cause. I removed the plugins, and the admin console loads. Thanks!

Hey cthesoup,

Were you able to identify the culprit plugin? I would like to improve Wildfire so that an error or warning could be printed (to the very least).

Thanks,

– Gato

I removed the search and registration plugin, but still get the error when accessing port 9090.

Did you have to restart the wildfire process or reboot to get it to work? I don’‘t want to bring this system down during the day so I’'ll try to restart tonight.

I was using 3 plugins: Search, I-Ball and Content Filter. Must have been one of those. Sorry I can’'t be more helpful…

List of plugins that need to be updated to be compatible with Wildfire 3.2.0 or newer:

. Asterisk-IM

. ContentFilter

. Gateway

. Subscription

. Wildfire Enterprise

. Spark Fastpath Webchat

I have no info about I-Ball.

Regards,

– Gato

Message was edited by: dombiak_gaston

Judging from this post I’'d say I-Ball is not compatible with Wildfire 3.2.0 or newer.

Cheers,

Ryan

Hey Ryan,

Good catch. I just posted a suggestion in that thread to see if the iBall plugin can still be used with Wildfire 3.2.0.

Regards,

– Gato

I’'m still unable to access my admin console. My problem is not a plugin conflict.

I believe that I have a configuration problem that was working with 3.1 and not compatible with 3.2.

thanks,

chrisj

Hey chrisj,

Could you elaborate a bit more about your setup and problem? Is the server starting up correctly? Do you see any error in the log files? What do you see in the info.log file? Is it just 9091 broken or also 9090? What do you see when you execute netstat -a | grep 9090?

Regards,

– Gato

Problem: port 9090 returns a HTTP ERROR: 503 SERVICE_UNAVAILABLE

Wildfire running, client can connect and are fully functional, Admin console returns error above.

I know that I had set a option in the console (cant remember which but I think it was the server name), with the older version (3.1.0) so my JID would match email addresses. now when wildfire starts I see in the stdoutt.log

Wildfire 3.2.0 Feb 8, 2007 6:02:21 PM

Admin console listening at http://domain.tld:9090

domain.tld is the email domain and not used on the host itself.

I would expect it to say

… listening at http://host.sub.otherdomain.tld:9090

which is the hostname for the box it’'s running on…

clear?

TIA,

chrisj

Message was edited by: chrisj_0

Message was edited by: chrisj_0

Hey chrisj,

Can you tell us how you updated your server? Do you see an admin folder inside the plugins folder? Also could you check the error logs in the logs folder? Have you configured Wildire to only listen on a given interface?

Regards,

– Gato

I updated the server with the rpm and followed instructions I found here for backing up and restoring the plugins and embedded db.

I do have an admin folder under plugins. It’'s the only folder I have because I deleted the others based on the posts above.

I don’'t believe I configured wildfire to listen on an interface.

Error log after my restart last night:

2007.02.14 18:17:00 org.jivesoftware.wildfire.stun.STUNService.startServer(STUNService.java:136) Disabling STUN server

java.net.BindException: Cannot assign requested address

at java.net.PlainDatagramSocketImpl.bind0(Native Method)

at java.net.PlainDatagramSocketImpl.bind(Unknown Source)

at java.net.DatagramSocket.bind(Unknown Source)

at java.net.DatagramSocket.(XMPPServer.java:148)

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(ServerStarter.java:93)

at org.jivesoftware.wildfire.starter.ServerStarter.main(ServerStarter.java:49)

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.install4j.runtime.Launcher.main(Unknown Source)

I just wanted to confirm I’‘m still having the same problem with the admin console on version 3.2.1. I backed up the wildfire.xml from the conf directory as well as my ./resources/security directory, deleted the whole wildfire install and unpacked the new tar.gz, copied the config and certificates back over (using MySQL) yet everything else works except for the web admin console. The log files don’'t seem to have any errors indicating anything other than that they are listed on 9090 and 9091 (with the correct domain) and the web interface continues to return the 503 error.