Admin login console missing

Hi guys.

When i try to log into the admin console, I get a page connect be displayed. The login.jsp page is missing. Can anybody assist me with this?


What OS is the server running on? Is this a new install? Has the server been previously configured?

It is running on Windows Server 2003. It was working and configured.

Spark still works, I just can’t log into the admin console to do anything.

I also have Microsoft sharepoint running on the same server but on port 80.

Has anything changed on the server computer (Firewall, etc)?

Regardless, you could do an overinstall of openfire using the same or a newer version. Be sure to backup your database first. This would place all the files back on your system.

I did do a reinstall and spark works fine, but I still can’t log into the admin console. the login.jsp file is still missing

What web address are you trying to go to specifically? Is it from a remote computer or local to the server? If it is an external database you could do a clean install after backing up the openfire directory. Once you do a clean install copy back the openfire.xml file and start the openfire server. You should be back in business.

I am trying to go to:

I am on the actually server.

The database is using the integarte database included with openfire.

That may not work after a certain security "fix’ is applied to the server. Mine no longer works either. Try this instead: http://localhost:9090/login.jsp. If that does not work try connect from a remote computer at the real DNS address.


Just a thought…does this path exist? C:\Program Files\Openfire\plugins\admin

A few times when I’ve deleted out the plugins folder I’ve also deleted out the admin directory which is where the web stuff is. I’ve had to install on my local machine, copy that folder over to the server’s plugin directory, restart the openfire server and then it works fine.

I kinda wish that admin folder wasn’t in the plugin directory…

unfortunately that didn’t work.

I have tried your suggestion to copy the admin folder, but still no luck.

are you still trying to go to the 127 address?

I have tried the internal IP address, localhost, and

All of them have the same result.

When I attemp to connect using https://localhost:9091, I get an error stating that it can not find login.jsp

At this point either something on your server is blocking access or the jar file that contains that jsp is corrupt or missing. I would backup the entire openfire directory. Uninstall the app, delete remaining folder from program files, reinstall same version, copy back the database and openfire.xml to the proper folders, start the server.

I copied the openfire directory.

I uninstalled openfire.

I rebooted and reinstalled openfire.

Can you please assist with the rest of the restore process?


You want to copy the folder embedded-db back into the openfire directory and the openfire.xml back into the conf folder. Then start the server and test.

Any change in your status with this?

I uninstalled 3.5.0 and installed 3.5.1 and did as you instructed with the embedded database and the openfire.xml file. Everything is working great.

Thanks for all the help.