Admin password keeps resetting


I have an installed and working copy of openfire, using mysql as the database backend. I’m finding that whenever i close the browser on the admin session and try to re-open it and log back in the admin password no longer works… I have to uninstall the program, delete the database and re-install for the admin console to work again. It’s done this on both a windows install and a gentoo linux install. Is there any reason why it doesnt take the password after the first session or an easier way to retrieve it other than a re-install? I had several days invested getting it configured for users/groups and working with our partners office, only to have the admin password stop working.


Edit: I have tried the reset method here d/ but it does not working saying there is no jiveuser registered.

verify that you have granted the correct rights to the database to allow the data for the admin account to be written. Additionally have you tried the config with the embedded database? Just as a test. External SQL is better for production.

I’ve tried both on the windows side and both did the same thing there. I will try it on the linux install and see what happens.

I’m pretty sure the perms are ok, as I was able to open close/restart openfire several times yesterday ( i checked several times over several hours after experiencing the issue previously and I didn’t want to spend to much effort for naught again).

I meant the permissions for the database. When you create the database you need to, or should, create a user to access it as well in SQL. This user needs full rights to the database.

I have done GRANT ALL ON openfire.* TO admin@‘’ IDENTIFIED BY ‘password’; openfire is connecting as admin to the db

When i was referring to be able to start/stop and open close, i meant i was able to login after doing all those things, so the password was working at that point. It did not work today however.

I have re-isntalled and tried the embedded db this morning and so far so good but i’d prefer to use the mysql backend if possible.

I only wanted you to try the embedded as a test. Production should definitely be on SQL. Are you using LDAP, are you logging conversations, etc? Can you start with a clean database and let the tables be created new?

I am not using ldap nor logging conversations. Each time this happens i have to drop the database and recreate it/add perms in order for me to be able to log back into the console so its always a fresh database.

I’ve been fighting the exact same thing, in another thread, and just found out something interesting!! I had created a new user for myself and clicked the “administrator” checkbox. I just tried logging into Openfire using my new username and WHA-LA!! It works! I can get in!! It appears that it is ignoring the user named “admin” or something. See if that works for you!!!

That was exactly it! Thank you, ive been struggling on and off with this for the better part of a week and was about ready to give up.