powered by Jive Software

Agents logging in default to "available"

Is there any way we could change this? We’'d like agents just logging into the system to default to “away”.

This is because it seems that went the Fastpath plugin loads it defaults agents to available, even if in Spark they are “away”. This leads to reps being on lunch, but still getting requests, etc, etc, because they just logged back into Spark and quickly went “away” before Fastpath loaded.

This is actually a bug. I have filed ENT-86 to fix this issue.

Thank You,

Derek

I’'m only replying because the bug report seems a bit vague, and I wanted to flesh out the details.

  1. Agent logs into Spark, quickly sets themselves “away”.

  2. Fastpath plugin loads

  3. Agent starts to get chats

  4. Hilarity ensues

The best case scenario for resolution would be a way to force our chat agents (we only use wildfire for click to chat, not enterprise IM) to be “away” when they first log in. Then they’'d have to actually do something to get chats (eg, changing their status from away to something else). This would ensure they were ready to chat when they started getting chats.

Actually, the ‘bug’ sounds more like what both of us want to do mruno.

bug says - [Logging into fastpath uses the users current presence, and no longer defaults to “Available”. ]

We need a similar functionality, the ability to make sure users log on in ‘Do no disturb’ mode so that they cannot get chats unless they change that status.

So if the package logged in using the same presence as when the users logged out, then that would be better than all of them logging in as available. At least a few users could be taught to go DND before logging out and those would be offline the next time they logged in as far as fastpath is concerned.

I guess finding this means I can stop looking for a way to change this option at startup, as it appears the developers intent is for users to log in as available only?

Please consider making this a selectable option!

Thanks!