AIM buddy list not populating on login

I’m having an issue where users connect fine to the aim transport and are seen online by AIM users but their buddy lists do not populate until they log off the transport and back on. Logging out of Spark and back in does not do it, they have to log off the transport only. Anyone else see this issue?

Spark 2.5.8

Openfire Ent. 3.4.4

IM Gateway 1.2.2a



I am having the same issue. Did you ever find out what exactly was happening?

I found that I had to remove the Monitoring Plugin in order to get the spark clients to load the AIM roster on login. I dont know why this is. Also, when I went to remove the monitoring plugin, in the error logs it kept saying that it couldnt be removed. In the end i just removed OpenFire and installed it again. I have tried this on both linux (ubunut 7.10) and windows server 2003, with the same results.

Are you sure this is a Spark issue then? it sounds more like a conflict between plugins in Openfire.

I think that you are correct. Everything is running smoothly now. But I still can’t run monitoring with out it getting all cranky again.

Very odd, I run the Monitoring Service plugin and the gateway plugin with no issues. Granted I am not logging chats on my production server but when I tested it on my testbed server there was no issue.

Yeah its werid because if i try to uninstall the monitoring plugin in the event log it just keeps saying “attempting to uninstall monitoring plugin”. I have had this happen to me on my Ubuntu dev box and a windows production server.

That is an ongoing issue with openfire. To easily remove plugins, I stop the openfire server, delete the jar fil and associated folder then start openfire server.

Ah, good to know. I have only just gotten involved with Openfire and

Spark. The only plugins that I am running right now are the gateway,

broadcast, and search. So far I have not found anything in the forums

that would lead me to believe that these are incapable with the

monitoring plugin.

They should not be as long as you are completely up to date with Openfire, Gateway plugin and Monitoring Service plugin.

I have been just activating plugins through the Plugin interface, and

checking to see if they were up to date through the automatic check on

the bottom of the page. Is there a different (better?) way?

This is what i have installed:

Openfire 3.5.1

Broadcast 1.7.0

IM Gateway 1.2.3

Search 1.4.2

Monitoring plugin version is 1.0.1

Those are all the most current versions. Odd indeed.