powered by Jive Software

Another problem with jwchat (part II)

hi all,

in this thread (http://www.jivesoftware.org/forums/thread.jspa?messageID=100136) Gaston helped me with jwchat using resin.

i was using it normally until i changed the port of jive c2s, the default 5222 to the one that here we use in the production enviroment, the 2510.

with this port, jwchat can’'t connect anymore…

i was so happy

ideas?

regards,

Rodrigo.

Oi Rodrigo,

Attached to this post you will find a modified jwchat version (100% unofficial version) that includes a modification so that you can configure the port of the XMPP server to connect to. By default the application will assume the port 5222 but you can set the system property variable named “xmpp_port” to override the default value. The exact way to set the system property in your application server may vary but in general you will need to add this parameter -Dxmpp_port=2510 to the command line where the JVM is being launched.

Let me know how it goes.

Enjoy,

– Gato

hi Gato,

i’‘m sorry, but i don’'t understand how to configure this parameter.

i just have to launch jive messenger like that: “/opt/jive_messenger/bin/messenger -Dxmpp_port=2510” it that it? i don’'t have to do nothing in the war file of jwchat that you send me?

thanks,

Rodrigo.

Oi Rodrigo,

Sorry for the confusion. To change the port in JM you just need to log into the Admin Console and change it from there (click on the button at the bottom of the main page) and restart the server.

The system property I was referring to is meant to be used by JWChat. So if you are using Tomcat to run JWChat then you will have to add that system property to Tomcat. You may use the “Monitor Tomcat” tool and set the new system property in the Java tab in the Java Options section.

Regards,

– Gato

hi Gato.

i know how to setup the port in the jive messenger to 2510, i’'m using it.

the problem is with jwchat, that only works when the jabber port is the default, 5222. when it’‘s other (2510) it don’'t connenct.

i use jwchat with resin, so what do i have to change in resin to make it works?

regards,

Rodrigo

Hey Rodrigo,

JWChat was always connecting to 5222. The modified war version that I attached in the previous post lets you change that value. To use the new war file with Resin do the following:

  1. Stop Resin

  2. Download the attached war file and copy it to the webapps folder

  3. Modify the way you are launching Resin to include the new system property. E.g. C:\installs\resin-3.0.14\httpd.exe -Dxmpp_port=2510

  4. Launch Resin

For more information about step 3 you can follow this link: http://www.caucho.com/resin-3.0/install/httpd.xtp

Regards,

– Gato

hi Gato,

thanks man, now i’'m connecting to port 2510 with jwchat.

what i want know now is if i could use this jwchat.war file that you modified in a production enviroment, or it’'s just for test?

if i can use in the production, how do i translate for brazilian portuguese (pt-br)?

i received from Stefan Strigler an pt-br.po to translate it, is there a way to use this file when i done the translation to translate it for portuguese?

thanks,

Rodrigo.

Oi Rodrigo,

Attached you will find the latest version of JWChat and JabberHTTPBind with the configurable port enhancement. If you are planning to add a new translation of JWChat then I recommend posting your questions to http://sourceforge.net/mailarchive/forum.php?forum=jwchat-devel. I really don’'t know much about JWChat.

If jwchat-1.0beta2.war is a stable version (you may ask that in their forums) then you can consider the attached war file as ready for production. The modification I made is really minor and it won’'t affect the functionality of the software.

Regards,

– Gato

hi Gato,

exactly what have you change in this .war file that you attached here?

i mean, what is the diference between this file and the original jwchat-1.0beta2.war file that is on the jwchat site?

and with the -Dxmpp_port=2510 option i’'ll be able to use any jwchat version or just this one that you send me?

regards,

Rodrigo.

The new attached file includes the new JWChat beta plus a modification that lets you configure the port to use to connect. That means that the -Dxmpp_port=2510 option will only work with the new attached version.

Regards,

– Gato

ok, Gato.

the main reasons why i choose jive messenger if that the easy web-based installation and configuration and the support that you give us. keep doing that!

thanks for all your help,

Rodrigo.

I use JM running in my local Network.

In client side, I use JAJC and It’'s Ok now.

But when I using jwchat and It does not work. My webserver is IIS (use for jwchat).

So when I run http://localhost/jwchat/index.html.html. And I can not login to my local JM server.

Can you help me? Thanks alot.

hi Gato,

here is another problem

now i’'m connecting to port 2510, but after a short time (5 minutes top) the jwchat gets this error message “Service unavailable”. do you know why is that and what i can do for that?

i post an message for jwchat forum but no one answer

regards,

Rodrigo.