powered by Jive Software

Another problem with reset password


#1

Hi
I have openfire 4.1.0 - what is a official instructions to reset admin password ?
Many many people give different answers …

I try … update via mysql:
"UPDATE ofUser SET encryptedPassword=‘my new password’ WHERE username=‘user@domena.pl’
i try change config xml.

I canot find a solutions with docu


#2

As far as I know ‘encryptedPassword’ must be cleared and ‘plainPassword’ must be set to new password. And after first successfull login with new password you just set up secure password in admin web-interface.


#3

Hi
Sorry but this solutions does not work :frowning:

BTW
why a simple solution to the problem is raised to makes life difficult…


#4

Maby solutions how to add aother user / admin ? I try insert in mysql seccond aaccound and not working and cannot log via web-interface


#5

I found out that there are several steps to reset password.

  1. Stop the OPENFIRE

  2. In openfire.xml add bold marked lines

<!-- root element, all properties must be under this element -->
<jive>
<admin>
<authorizedUsernames>admin</authorizedUsernames>
</admin>
<adminConsole>
<!-- Disable either port by setting the value to -1 -->
<port>9090</port>
<securePort>9091</securePort>
</adminConsole>

  1. Execute command

UPDATE ofUser SET plainPassword = ‘newPassword’ , encryptedPassword=NULL WHERE ofUser.username = ‘admin’;

newPassword - place your new password here

admin - name of admin user

  1. Start OPENFIRE

And the last way: execute command INSERT INTO OFPROPERTY VALUES('admin.authorizedJIDs','admin@server_name,one_more_admin@server_name ').
I hope this way helps.


#6

Hello
Thenx but this solutions open a new installer / new all configurations… ask me mysql connections user/ password etc…


#7

If it starts new installation then you must check line in openfire.xml

  **<setup>true</setup>**  
</jive>

If config file openfire.xml misses that string then web-interface starts in new installation mode. Add this parameter and you get normal web page.


#8

I have this line