powered by Jive Software

Apache2 + mod_jk + tomcat5 + JabberHttpBind0.3 + wildfire2.5 + jwchat1b2

i can get jwchat and ejabberd running just fine – now i’'m trying to get jwchat to conenct to wildfire –

working for a few days on this one:

apache:80 and tomcat:8080 startup fine, apache will serve php files fine, and tomcat will serve jsp/servlets fine. The ‘‘Tomcat-Apache’’ service is also listed in the tomcat web admin and the ‘‘catalina.out’’ file shows no errors on start up or shutdown.

the JabberHttpBind servlet worked right outta the box too.

the problem is that i get this error when i try to go to the directory that is supposed to serve from tomcat via mod_jk:

No Host matches server name cubeone.no-ip.org[/b]

Your browser sent a request that this server could not understand.

Additionally, a 400 Bad Request error was encountered while trying to use an ErrorDocument to handle the request.

Apache/2.0.54 (Fedora) Server at cubeone.no-ip.org Port 80[/i]

its not a regular apache error message, so some element of the (mod_jk.conf + apache directives + tomcat service) must be correct, it seems to be related to virtualhosts, but no matter what alternate configs i try, nothing works – the seemingly best results yeild when i run the tomcat services (catalina, tomcat-apache) with ‘‘localhost’’ set as the default host.

i’‘ve googled the hell outta this and i just can’‘t seem to get the two servers to link up. and i guess even if they did link up, there are still a coupla steps left to get jwchat configured to see the http-poll – that’‘s if i’'m lucky

anyone have this scenario working, anyone, Bueller?

Hi Zeuben,

I hate mod_jk but I love mod_proxy. So my Apache uses mod_proxy and connects to the Tomcat http port (default 8080). I don’'t need no http-poll setup this way. So I can test everything without Apache using http://localhost:8080/jwchat

It’‘s a good thing to use Apache to proxy only jwchat URL’‘s and no web admin URL’'s, I use mod_rewrite to do this but maybe < Location … > could also do it.

You may also like muckl (also from the jwchat author).

LG

ok it2000,

that sounds like a solution.

could you provide a guide / steps to explain what you did to get this working?

Hi,

I assume that your Tomcat is running fine.

This is the idea behind mod_proxy (for Apache 2.0.x) together with mod_ssl and without security for the admin console:

LoadModule proxy_module modules/mod_proxy.so

LoadModule proxy_http_module modules/mod_proxy_http.so

ProxyRequests Off

/code

LG

rad.

i’‘m’'onna try this shiite when i can keep my eyes open.

word homeboys.

i’'ll report back.

thank you.

tried putting that in the httpd.conf a couple different ways. apache starts up with no errors but nothing works – blank pages for everything. If i comment out the proxy stuff, everything is back to normal. no idea.

Hi,

this is a sample to include into the ssl.conf file of Apache. Use the lines without VirtualHost if you want to try it for http port 80:

ProxyRequests Off

ProxyPassReverse / http://jabber.myhost:8080/

/code

LG

well, i added that to the ssl.conf and the pages show up now – but i’'m still getting the same error from jwchat when i log in.

    RewriteRule ^/http-poll/$ http://cubeone.no-ip.org:5280/http-poll/

    RewriteRule ^/\/JabberHTTPBind/$ http://cubeone.no-ip.org:8080/JabberHTTPBind0.3/

it works if i run ejabberd (:5280 is the internal proxy for ejabberd), but with wildfire i get a javascript alert saying ‘‘internal server error’’.

Message was edited by: zeuben

ok – i jimmied some stuff around, and now, when i goto: webroot/jwchat/JabberHttpBind/ – the proxied page shows up – i assume this is good, and how it should be working. however when i try to log in – i still get the same ‘‘internal server error’’ message. i even tried the jwchat running on tomcat – and i get the same error. is this an issue with wildfire?

Hey zeuben,

Could you check for errors in the log files? BTW, JWChat should be working fine with Wildfire.

Regards,

– Gato

nothing in the wildfire logs — here’'s my current config:

wildfire – binary install, not tomcat.

jabberHttpBind – tomcat servlet or punjab on apache:5280

jwchat in apache-webroot

i’‘ve followed every single guide out there – the only time JwChat will work is if i run wildfire on the tomcat server. i don’'t want to do this b/c plugins are not available this way.

if i run the binary install of wildfire and try an use JabberHttpBind or Punjab – i get ‘‘internal server error’’ from JWChat.

i’'ve tried everything. I get this error with any method i try – tried them all – mod_rewrite, mod_jk, modproxy — all give me the same error. the only way this has ever worked with wildfire for me is if i run wildfire under tomcat – which i do not want to do.

anyone know what’‘s up with this? it’'s gotta be some small thing – GRRR

Hi,

I’‘m running the search, broadcast and presence plugins in Wifi/Tomcat, so I don’'t see a plugin problem.

Did you also try TomcatjwchatjabberHttpBind and a standalone Wifi installation on the same server? This should run fine and if it does you may use Apache+mod_proxy to map port 80 or 443 to Tomcat port 8080.

LG

yeah if i run everything on tomcat it works –

you say you got the plugins to deploy on tomcat – how? i read it doesn’'t really work, as they are compiled .jsp pages.

i can’‘t seem to get mod proxy working for some reason – i don’‘t think – do you have a quick how to – i’'ll do some searching and see if i can find where i went wrong.

i have no problem running the tomcat version if plugins work. – but no matter what i would like to figure out some way to map tomcat into the apache webroot.

Hi,

“did you also try TomcatjwchatjabberHttpBind and a standalone Wifi installation on the same server?” was my question and this means Wifi is not running in Tomcat.

May I ask which plugins are causing trouble? I don’'t see compiled jsp problems, anyhow you could use a standalone Wifi to configure your plugins and then run Wifi in Tomcat using the existing configuration without accessing the pages.

LG

i do have a standalone WiFi installation which works great.

RE: plugins – where do you deploy the plugins under tomcat? – there is no plugins folder. i tried creating it but nothing happens even with plugins.xml in the directory.

Hi,

put them in the Wifi home directory, my one looks like this:

WILDFIREHOME

conf

embedded-db

logs

plugins

broadcast

presence

search

resources

/code

LG

yeah – that’'s the standalone install —

i’‘m talking about the tomcat version — plugins don’‘t show up in the admin – and there is no plugin folder by default… the standalone version works great – except i can’'t get httpBind to work.

Well, that’‘s also the Tomcat version. There’'s just no admin folder in Wifi home.