powered by Jive Software

Appdata Directory & Other Weirdness

First I want to say how absolutely fantastic Spark is! I have a spark environment that has existing users and has been running for nearly 6 years without major incident on multiple Windows OS’s (xp-10). Recently though I have 2 users that just got new Windows 10 computers (these are not the first win 10 systems we have used for spark, nor are the users new to the environment) and for some reason the c:\users{JSmith}\appdata\roaming\Spark directory did not get created. I logged in as another user, MJones, launched Spark and it created the directory for the c:\users{MJones}\appdata\roaming\Spark account. I logged out of MJones and back into the JSmith, then launched Spark again and still no roaming directory appeared. I then copied the MJones appdata\roaming\Spark directory into the JSmith appdata\roaming directory and still get weird issues like no text appears in messages if the chat window is not opened, JSmith password is saved as incorrect and has to re-enter it (both of which were the original issue before discovering the missing appdata\roaming\Spark directory). I then deleted the copied MJones appdata\roaming\Spark directory from the JSmith appdata\roaming.
Does anyone have any ideas on what might be causing this and how to fix it? My next step is to delete the Windows 10 JSmith profile, but I would like to avoid that if I can.

So, can the user with the problem login to Windows on other identical PC and run Spark? If not, maybe there are some non standard symbols in the Windows username? What Windows 10 version? 1803?

Yes, both users that are experiencing problems are able to log into windows and run all other apps/programs correctly (email, web utilities, printing, etc.). Both users have also been users for 2-3 years with no changes to their accounts outside of password and only recently (within 2 weeks) changed from Windows 7 computer to Windows 10 computers (though there was about 20 others from the same unit that made that same change at that time). The Windows 10 version is 1803 & Java is the current version.

Try to login with problematic Windows user on Windows 10 which works fine for another user and see if it has the same issue with Spark then.

Also, what Spark version?

Current version 2.8.3