powered by Jive Software

Asterisk-IM configuration

Hi to all… I’ve a problem with Asterisk-IM configuration.

On my LAN i’ve two PC: one with Asterisk 1.4.9 on Debian Etch (; other of these with openfire 3.3.2 on WinXP (; database embedded).

Now, i’d run integration through Astererisk-IM, but it doesn’t work.

When openfire start, i’ve message in openfire console:

Missing database schema for asterisk-im. Attempting to install…

asterisk-im - Database update failed. Please manually upgrade your database.

What means??

And then, when i try to add server in asterisk-IM tab, it says “Server created successfully”… but it isn’t true:

in the next screen message is always “No Servers Configured”. WHY??? Help me!

and i’ve another message:

29-ago-2007 13.18.49 org.asteriskjava.util.internal.JavaLoggingLog info

INFO: Connecting to

29-ago-2007 13.18.49 org.asteriskjava.util.internal.JavaLoggingLog info

INFO: Connected via Asterisk Call Manager/1.0

29-ago-2007 13.18.49 org.asteriskjava.util.internal.JavaLoggingLog info

INFO: Successfully logged in

29-ago-2007 13.18.49 org.asteriskjava.util.internal.JavaLoggingLog info

INFO: Determined Asterisk version: Asterisk 1.2

29-ago-2007 13.18.49 org.asteriskjava.util.internal.JavaLoggingLog info

INFO: Initializing done

My manager.conf is:



read =…all…

write = …all…

Thank you!


I’m very new to this but I found that if you are using the embedded (HSQL) database then the tables are not created correctly.

Modify /plugins/asterisk-im/database/asterisk-im_hsqldb.sql to read as below, restart openfire and try to add a server again - hopefully it will work for you.


create table phoneServer (

serverID bigint not null,

serverName varchar(255) not null,

hostname varchar(255) not null,

port integer not null,

username varchar(255) not null,

password varchar(255) not null,

constraint phoneServer_pk primary key(serverID)


create table phoneDevice (

deviceID bigint not null,

device varchar(255) not null,

extension varchar(255) not null,

callerID varchar(255),

isPrimary integer not null,

userID integer,

serverID bigint not null,

constraint phoneDevice_pk primary key (deviceID)


create table phoneUser (

userID bigint not null,

username varchar(255) not null,

constraint phoneUser_pk primary key (userID)


create unique index phoneUser_username_idx on phoneUser(username);

INSERT INTO jiveVersion (name, version) VALUES (‘asterisk-im’, 2);

1 Like

Thank you very much! Now it’s running correctly!


I just finished a new install of Openfire and was trying to get the embedded DB working. The fix to the DB install worked 100%.

I was having the same problem on 3.3.x and forgot about it when I decided to go with MySQL. Obviously this is still an issue for Asterisk-IM and the embedded DB.

This really needs to be in 1.4.1 or 1.4.0a or something.


I’ve created PHONE-71 for this. The fix will be part of the next release.


Is there any rough estimate about when the next release will happen?




Thanks a lot Chris Stone! you’re the man!

jonie e

Thank you Chris Stone for that info, I’ve got the server listed,but now it doesn’t seem to be active as there is no green dot, instead its a grey dot.

These are my configuration details:

Openfire server: running on Windows server 2008, Domain=tnkochi.com, ip address:

Elastix server: running on Linux server(This machine is part of the same network, but NOT a part of my domain tnkochi.com), ip address:, Iptables on this machine are turned off.

This is my /etc/amportal.conf








This is the configuration of the server that I’ve added in the Asterisk-IM

name:localhost(I’ve also tried ‘localhost.localdomain’ which is the hostname of that machine)





Should this linux machine be added to my Windows domain to establish a connection?

Please help me out here, Thanks in advance.

Great, I know why,

serverName varchar(255) not null “unique”, he can’t be unic, because not bind correctly with constraint phoneServer_pk primary key(serverID).

U are great Thx 2014 and more years !