Asterisk-IM Problem


I’'m running Wildfire 3.0.0. on a Trixbox 1.1.1 server and have installed Asterisk-IM onto wildfire.

My problem is when I now click on the Asterisk-IM tab on the Wildfire Console, I just get a blank screen, I can’'t make any amendments to the config, or look at the phone mappings page.

I then tried to deleted the Asterisk-IM plugin, and re-installed it, but got the same problem

If anyone has a fix for this, I would be grateful to know what it is! Failing that how can I completely delete the plugin to try a re-install?

Thanks in advance,


Additional Info… I just upgraded to Wildfire 3.0.1. Its still doing the same thing!! I notice others have had a problem using this plugin with 3.0.1, although they seem to indicate only the phone mappings page is blank, whereas my problem all the asterisk-im pages are blank! So suspect that I have a slightly different problem!

Additional, Aditional info!: I have now fixed my problem with the totally blank Asterisk-IM plugin, and am left with just the blank phone mappings page, the same as the others who are running WF 3.0.1

Went into server properties and removed the wrong Asterisk Manager username, then disabled asterisk manager from the same page, I was then able to see the properties of Asterisk-IM and change them to the correct values.

I am running a similar configuration of Wildfire and Trixbox. I am also able to put config settings in the astrisk IM plugin first page. It appears to connect successfully (ie I don’'t get an error)

the phone mappings page is blank though. Is there a solution to this?

I have read and re-read the IM plugin configuration instructions but the part about client initialization has me baffled. It appears to be a command that I put into one of the two programs (one would think it would be Wildfire) but it’'s not clear which one I need to run that command, I can not find a CLI on either installation.

Granted, I tried to get into the SSH terminal thing from the Trixbox main webpage but I don’'t know what username to put in there. I put everyone that I know about that I used for Trixbox but nothing is accepted. I guess I could hook up a keyboard to the Trixbox box and see if the command works there.

Hoping for someone to put how to configure the SIP extensions into wildfire in real laymans terms for me.

I am

Message was edited by: alan.n

The SSH user name and password are…

When you first connect via the ssh, it wants the ‘‘maint’’ user name and password. Once you have your logon promot, it wants your ‘‘root’’ username and password.

How did you get the problem fix i am having the same problem running the same vrs as you. i try to delet and reinstall, but it did not work.



Did you ever get this working? I have similiar problem


I have got rid of this problem…

Firstly U need to configure asterisk agi-manager then try to configure the IM plugin…

Thanks & regards,


So what your saying is install the plug in then go to server preferences config there then the page will appear.


Re: blank phone mappings page

This problem has been fixed by a patch written by hcouplet: 0

Compiled versions are available in this thread. He has also fixed the “users always on the phone” error.