powered by Jive Software

Audit policy not logging all conversation

Hi,

I am using openfire’s audit policy to log all conversation as per company policy.

But as i have noticed, not all conversation are being logged. Here are my settings for the audit policy:

Folder to save the files: /opt/logs/openfire

Maximum size of all files (MB): 100000

Maximum file size (MB): 100

Maximum days to archive: -1

Flush Interval (seconds): 60

No log file ever reach 100MB. What settings can be changed to what value to achieve a 100% logging of conversations?

I am using openfire 3.4.5 and using LogViewer 1.1. from BaqKyra Software to view the logs.

thanks and best regards,

Kenneth

dear keanne,

please change your

Maximum size of all files (MB): parameter to under 2000MB because auditor uses integer which will restrict the file max on under 2GB

I have the same problem with you and it solved after I change

Maximum size of all files (MB): parameter to 2000MB

I am having the same issue. Here are my settings

Folder to save the files: /var/log/openfire/logs/

Maximum size of all files (MB):2000

Maximum file size (MB): 100

Maximum days to archive: -1

Flush Interval (seconds): 60

Running on A CentOS Machine. I made the change from 100000 to 2000 as suggested but it did not affect the results.

This is an example of the log file information (domain.name is not the real address)

<packet xmlns=“http://www.jivesoftware.org” streamID=“ddafcc7c”

status=“auth” timestamp=“Mar 19, 2008 04:45:18:265 PM”><presence xmlns=""

id=“wG4j8-27” from="walter@server1.domain.name/spark"

to="kelsey@server1.domain.name"><status>Away due to idle.</status><priority>0</priority><show>away</show ><x

xmlns=“vcard-temp:x:update”><photo>5a15e0e51f80ca9af15eefca4ced00ebe9bb e958</photo></x><x

xmlns=“jabber:x:avatar”><hash>5a15e0e51f80ca9af15eefca4ced00ebe9bbe958& lt;/hash></x></presence></packet>

So should the text of the IM be in this log file?