powered by Jive Software

Auth with LDAP but initially use display name instead of SamACCOUNT

Hi All,
The subject doesn’t explain this well, I apologize. I’ll try to explain it better here. I’ve got an Openfire 4.3.2 server using LDAP auth. We are using Spark 2.8.3.
Our Active Directory\LDAP logins are different than our display names, they are just numbers. When I have the server set to use the SAMname for the account name and users message a co-worker all they see is the number until both parties add each other to the personal contact list.
When I set the server to use the AD display name as the login, the name shows up in the contact list right off. The problem here is we need them to log into spark with their AD number, not their display name.

Any thoughts and help is appreciated.

all you want to do is update the vcard system property. I think the tag you are looking for is nickname . change it to {displayName}

Unfortunately that doesn’t change anything until after the user has requested to “subscribe” to the other user. I need it to display immediately.


it should update automatically. you are likely seeing a caching issue with the client.

You may be right, looking at the vCard for a user I just searched for doesn’t show any of their info. I will make a post in the spark forum.

OK, wroot in the Spark forum said that vCard info isn’t shared until the subscription is confirmed. This looks to be accurate since as soon as the other user clicks ok, the info populates.

I’ve enabled shared groups which is working, but a bit cumbersome. The subscription plugin would be ideal, however that isn’t working. I’ll open a new thread on that.