Authentication Problems

I currently have Openfire installed on a debian server but cannot log in via the Spark client. I receive an Invalid username or password message everytime.

My Openfire server is using LDAP to authenicate with Active Directory, this seems to be working as the user and group lists have been populated and I am able to login to the Admin console with my AD username and password.

There are no errors in the error log and I have tried logging in with various username & password combinations e.g.

ADUsername & Password

ADUsername.OpenfireServername & Password

Any idea whats going wrong here?

two questions for you. First (and this really shouldn;t make a difference but it is a nice test) have you attempted to log in with another client to see if you get the same error. Second, how are you authenticating to AD? direct or through ADAM? Also, what does your search filter look like?


Thanks for your suggestions.

I have now solved the problem, an installation of ejabberd was listening on port 5222 therefore openfire could not bind to the port.