powered by Jive Software

Binding OpenFire to an interface

I have installed OpenFire 3.3.2 on my test server, (we have 3.2.4 in production, and will be upgrading soon). One of the thing I’d like ot be able to do is bind the Openfire server to a specific IP, with the aim of running two seperate, unconnected servers on the same server, using different IPs.

I changed the openfire.xml file and added the Interface ip, as directed in the documentation, but when I restart the server, it still answers on both the public IP and on localhost, and when I log into the admin console, it still says it’s listening to all interfaces. I tried setting the openfire.xml file to listen only to localhost, with the same results.

What am I overlooking? Assistance is appreciated.

Hi,

is it possible that your configuration looks like

So you did add the IP address but the network.interface=10.1.2.3 is still commented? Removing “<!” and “>” should help if this is the case. Otherwise you may want to post the relevant part of your openfire.xml file.

LG

Oh wow. I feel stupid. And contagious.

Thanks!