powered by Jive Software

BOSH server only acting like web server

I am using Openfire 3.8.2 and I am trying desperately to set up a web client like jappix or jwchat. The host is running CentOS 6.4. In openfire’s web admin i have enabled the http Binding service on port 7070. However when I go to myserver:7070/ i get a directory listing with an index.html.old and a WEB-INF dir. and if I point it to myserver:7070/http-bind/ I get a 404. to verify my belief that this is not working i ran the followning command:

curl -d “” http://myserver:7070/http-bind/

and the result i get is this:

Error 400 Bad Request

HTTP ERROR: 400

Problem accessing /http-bind/. Reason:

    Bad Request

Powered by Jetty://

for fun here is the result of running against myserver:7070

Directory: /

Directory: /

WEB-INF/ 4096 bytes May 29, 2013 6:12:44 PM
index.html.old 222 bytes Mar 3, 2013 9:13:10 PM

I have tried turning it off, saving andturning it back on, I’ve tried changing the port, nothing works. I would verify the config files are updating appropriately but I can’t seem to find where Openire keeps it’s configs. Any help would be greatly appreciated.

The root folder is OPENFIRE_HOME/resources/spank

I know where the root of the server is, I need it to actually act as a BOSH server though. Currently it is just acting as a web server, serving html. I am using Apache to serve the web chat app, but I need the BOSH server to use it.