powered by Jive Software

Brazilian Portuguese Translation

Hello, I’'m doing the translation to Brazilian Portuguese, however I have difficulties to test the translation. The console screen is always in English, although I follow the the documentation of the Jive.

Could anyone help me to solve this?

Is it necessary use native2ascii?

Oi Sylvio,

Good to hear that you are doing a Brazilian Portuguese translation. To test your translation you should change in the jive-messenger.xml file the locale to be: pt_br and your resource bundles file should be messenger_i18n_pt_br.properties.

Since Portuguese has some special characters like á ã ê you can replace those characters with the corresponding &ampersand; entities. For instance, you can replace á with á or ê with ê. For more information follow this link http://www.pemberley.com/janeinfo/latin1.html. Other option is to use native2ascii.

Once you have finished the translation feel free to send it to me by email.

Obrigado,

– Gato

I still have same problem. The admin console remains in english.

Oi Sylvio,

Are you building Messenger or are you using it with an out-of-the-box installation? Make sure that the properties file is in the right directory otherwise the english version will be used. If you are building Messenger (i.e. using ant) then your file should be present in src\i18n. But if you are using it with an out of the box installation then you will have to add your file to messenger.jar.

Let me know if that helps.

Regards,

– Gato

Ola Gato.

I’‘m using a out of the box installation. I put the file (messenger_i18n_pt_br.properties) into messenger.jar and configured the locale in jive-messenger.xml to pt_br, but nothing happens. It stills remains in english. I’‘ll send the file (translation isn’'t complete). Could you test it, please?

Sylvio

Hey Sylvio,

Sure. Send it to me and I will check it.

Obrigado,

– Gato