BROADCAST plug in does not work on fresh installation

Hi All,

I just performed a fresh installation of OPENFIRE 3.6.2 on a WINDOWS Server 2008 test bed machine and I additionally registered the latest BROADCAST 1.7.0 plugin. The installation was done on a Microsoft SQL Server running on the machine.

However, the plugin BROADCAST refuses to load properly and in the warnings log a message is continously being displayed saying:

2008.11.25 14:30:14 Error unloading plugin broadcast. Will attempt again momentarily.

Additionally in the error log the following message is being displayed regardless if the BROADCAST plug in is registered or not.

2008.11.25 14:29:20 [org.jivesoftware.util.log.util.CommonsLogFactory$1.error(CommonsLogFactory.jav a:88)
] Line=19 The content of element type “dwr” must match “(init?,allow?,signatures?)”.

Anyone has any idea on how to make the plugin work correctly or what the second error message reffers to?

Any help will be highly appreciated.

Thank you all in advance.

George

To remove the plugin and reinstall, stop openfire server, navigate to the openfire plugins folder. delete the jar file and the folder it created. Restart openfire. Go to the admin website and download the latest broadcast plugin. If you get errors again. Manually download the plugin from the igniterealtime.org site on the Server 2008 machine and copy the file to the plugins folder of openfire with it stopped. once it is there start the server. This plugin allows for broadcasts from the server. spark the client can broadcast regardless.

First of all thank you very much for your kind answer. I have managed to make the BROADCAST plugin to work as you have suggested with no warnings produced this time. However, although that the plugin seems to be running when I sent a message to all@something.com as the instructions suggest nothing happens at all. I tried to send the message to all@… from the Spark clinet to other connected users to the server, but nothing happens. I also tried to send it programatically, but again nothing.

Spark has its own builtin broadcast function that is not reliant on this plugin.

ScreenShot013.jpg

If you want to use the plugin you need to configure your system properties as described here:

Configuration

The broadcast plugin is configured via Openfire system properties. These can be configured under Server/Server Manager/System Properties:

  • plugin.broadcast.serviceName – the name of the broadcast service. If no value is set, the default is “broadcast”.
  • plugin.broadcast.disableGroupPermissions – true to allow any user to broadcast a message to a group. When false, only group members or administrators can broadcast messages to a group. The default value is false.
  • plugin.broadcast.groupMembersAllowed – true to also allow group members to send broadcast messages to groups they belong to. When false, only administrators can send broadcast messages to a group. The default value is true. Note that the property value of plugin.broadcast.disableGroupPermissions can effectively override this value by letting anyone send broadcast messages to groups.
  • plugin.broadcast.allowedUsers – the comma-delimitted list of users allowed to broadcast messages to all connected users at once. When this property isn’t set, anyone is allowed to broadcast messages to all users. Users should be specified by their bare JID (e.g. john@myserver.com)

Using the Plugin

To send a broadcast message, send a message to all@[serviceName].[serverName] or [group]@[serviceName].[serverName]. For example, if your server is called foo and the default service name is being used, a message to all@broadcast.foo would be broadcast to all users connected to the server. For the group staff, a message to staff@broadcast.foo would be sent to all users in the group staff that are currently online or offline.

Note: for maximum compatability between group implementations, it’s recommended that you use lower-case group names in conjunction with the broadcast plugin.

Dear Todd,

Thanks again for the reply. It seemed my solution was a little different since I found out that I should be using an address like all@broadcast.myserver.com not just all@myserver.com. Having corrected this everything works as expected.

Thanks again for all the kind help.

Regards,

George

Right that is the first part of the settings: plugin.broadcast.serviceName – the name of the broadcast service. If no value is set, the default is “broadcast”.

Don’t forget to award points for correct and helpful answers.