powered by Jive Software

Bug: Admin - edit server settings

When editing the server settings in the admin console I get the message " Please enter a valid port number or restore the default." when the input is blank because in the non encrypted port is disabled with -1 in wildfire.conf The input refuses to accept -1 as a valid value.

So when using this, the admin console is forced to be open on the non-encrypted port.

Also this saves wildfire.conf with world readable permissions, letting anyone read the configuration file which has the database password clearly written in it.

Hi,

you could enter 65537 and save it, this will disable the port but throw an exception while starting.

You can track this issue: JM-689

LG

2006.05.16 20:55:48 [org.jivesoftware.wildfire.container.AdminConsolePlugin.initializePlugin(AdminC onsolePlugin.java:197)

] Trouble initializing admin console

org.mortbay.util.MultiException[java.io.IOException: Could not create JsseListener: java.lang.IllegalArgumentException: Port value out of range: 65537]

at org.mortbay.http.HttpServer.doStart(HttpServer.java:686)

Also this saves wildfire.conf with world readable

permissions, letting anyone read the configuration

file which has the database password clearly written

in it.

Hi,

does it help to set the permissions of the conf directory to protect the file?

LG