powered by Jive Software

Bug fix - Openfire cannot handle certain characters


#1

Hello, I have fix for a bug in the JID.java file.

To reproduce the issue you need to enter either “¸” or " ˘ " into the username field of the fastpath webchat. When you use these characters and click the “Send Message” button it will not connect to an agent.

Dubugging the source code showed that openfire server was not capable of handling there characters.

These are just two example characters that didn’t work but there are many and is therefore an important fix for a multilingual product.

I have attached a patch for this and using I’m using version 3.6.4.

Let me know if you need more information or help trying to get this into the product.

I am a software engineer at Sword Ciboodle. We have fixed bugs in the openfire product before and sent patches. Could we have SVN access to commit any future fixes?
JID_patch.txt.zip (2228 Bytes)


#2

Did you try to escaping the characters as recommended by http://xmpp.org/extensions/xep-0106.html


#3

The patch escapes the characters. If I were to escape the characters before it went to the server, it would still fail. The JID cannot unescape a character more than 2 bytes. Could you raises a Jira regarding this?


#4

Thnaks Chris for the explaining that. Could I ask you to please re-post your bug fix to the community planning group where it will get attention

http://community.igniterealtime.org/groups/community-planning


#5

No problem. At Sword Ciboodle we use openfire and often come across bugs and give our clients a modified version of openfire. We would like to contribute to bug fixes to help out with this product. Are we able to have access to JIRA and SVN?


#6

OF-568 is linked to this issue.