powered by Jive Software

[Bug ?] ldap connection timeout not working with SSL

After R&D i come to know its not possible, LdapManager already use this function for 10seconds delay.

http://www.igniterealtime.org/issues/secure/attachment/10250/LdapManager.java

// Specify timeout to be 10 seconds, only on non SSL since SSL connections
            // break with a teimout.
            if (!sslEnabled) {
                env.put("com.sun.jndi.ldap.connect.timeout", "10000");
            }

It's now hurts me , i use SSL connection with ldap, so some chance of fixing it in future
or its a bug ?. I think SSL is know the common protocol and it must need to be fix.

Muzi.

So far i dont see it as a bug (i’m not a coder myself). You could explain your problem better. I see that Openfre has 10000 value hardcoded, and you wnat 5000? You request is more an improvement request to me, than a bug report. Explain why do you need 5000.

Hi Wroot

I have no objection also for timeout limit 10000 but using 5000, imporves the stability also in fail over case if primary ldap is down.

But as i experinced and R&D ldap.connect.timeout not work with SSL, the url of LdapManager.Java i already posted in previous reply and here below another reference in which Mr Matt disables ldap.connect.timeout for SSL connections in 2.1.5 release and still its disabled in 3.64, SSL is very common protocol and i think its need to be fix for this.

http://www.igniterealtime.org/community/thread/14823

So i want to use this option (ldap.connect.timeout) for SSL connections, you please kindly confim as i am 100% confirm its disabled for SSL connections.

So its effects the usage of failover incase of primary ldap is down/network timeout. Currently its not working with SSL.

Kindly suggest & thanks for your suggestion and comments

Ok. I’ve tried to file this in the bug tracker. OF-332

Rigth so much thanks wroot, to take this seriously.

Muzammel