powered by Jive Software

[bug] mssql 2005

Hello,

After setting up the OpenFire database with these instructions for MSSQL, I receive the following errors after running the openfire_sqlserver.sql script:

Warning! The maximum key length is 900 bytes. The index ‘ofRoster_jid_idx’ has maximum length of 2048 bytes. For some combination of large values, the insert/update operation will fail.

Warning! The maximum key length is 900 bytes. The index ‘ofSASLAuthorized_pk’ has maximum length of 4128 bytes. For some combination of large values, the insert/update operation will fail.

This 900 byte limit is built inside MSSQL, so I’m not sure what the resolution is, but it could be dangerous.

The database is Microsoft SQL Server 2005 SP2 on Windows Server 2003 Standard x86_64, OpenFire 3.6.3-1 (RPM) on CentOS 5.2.

Thanks.

Good morning:

This should not cause a major problem because it is an index but is not the primary key. It may retreive records incorrectly but should not hurt anything. Really don’t know where the rosterID and JID would be used. Can someone else chime in.

How did you get Openfire to connect to the MSSQL database. None of the methods I’ve tried work. I get the user entered is not trusted. Can you please help me? Yes, I have MSSQL configured in mixed mode and tcp/ip enabled. The only difference I see is I’m running SQL 2008 Express and you’re using SQL 2005.

Thanks

I didn’t really do anything different, it just worked out of the box. Granted I have awesome DBAs, so I usually ask them to do something and it magically works. Sorry I can’t be of more help.

I ran into this issue too. I have since started using mysql. I think I might have found a solution, but I don’t have a good way to test it. I have attached my mssql script, but I never really tested it. I know very little about sql, so it could be a mess, but maybe it will work or help. I don’t know!
TESTopenfire_sqlserver.sql.txt.zip (2671 Bytes)