powered by Jive Software

[Bug] OpenFire "Require encryption" still allows unencrypted

I’m using OpenFire 3.9.3 on CentOS (RPM install).

As per the XMPP community general concensus, I’ve set the server to require server to server encryption. Unfortunately, t seems OF is still allowing unencrypted connectiosn to servers that do not support encryption (e.g. gmail.com, geeks.cl, phcn.de). OF should not allow these connections with required S2S encryption, so that would be a bug in OF, I think.

Related server configuration settings:

Server Connection Security