powered by Jive Software

Bug? Upgrade to 2.3.0 and now: Connection closed before session established

to be exact the error in logs reads as follows


2005.11.06 00:40:06 org.jivesoftware.messenger.net.SocketReader.run(SocketReader.java:151) Connection closed before session established

Socket[addr=/10.0.0.110,port=1127,localport=5222]


this only happens with 2.3.0 beta. downgrading to 2.2.0 solves the problem.

Here are some of the things I’'ve noticed with the beta which may or may not be related:

-Only one local client can connect to the server

-If i allow users to register their own accounts even that doesnt work, and user is prompted to make a new account (which obviously conflicts)

-Clients complain to the effect of


*** Connection lost to server.

*** Creating connection "brian@10.0.0.10/Trillian"

*** Stream error: host-unknown

*** Disconnected.


-The timezone in the languages menu resets to 0 no matter what time I select and save

Have tried:

-Logging in by IP and by domain name

-Toggling settings under registration policies section of Server tab

-Reinstalling 2.3.0

-Creating users manually and connecting clients to them

-Adding users to a group (grasping at straws)

-Different clients (gaim, trillian, faim for linux)

Again, this problem only manifests when using 2.3.0. 2.2.0 works fine (but not with Asterisk-IM, so I’'m SOL in that regard).

I know there was another post similar to this one a few days back, but in that thread people were able to login using ip addresses instead of domain names. i cant do that.

Thanks in advance,

Brian

(shameless bump)

Hey Brian,

In the latest nightly build we disabled the host checking (by default) so you will no longer have this problem. However, note that XMPP servers will require XMPP clients to use the correct hostname when validating or otherwise the connection will be closed after sending a stream error to the client as you just saw. In order to make things easier for clients we decided to disable the chekcing by default. However, it is still possible to enable the host checking if you need to.

Let us know how it goes.

Regards,

– Gato

So now i dont have to reconfigure my clients? My clients are connecting like user@IP, but the server is ‘‘jiveserver’’. So i have started changing it to user@jiveserver and adding host in connection tab as IP. have reconfigured almost the half of clients, but would be glad to hear if i dont need to continue. We will never had a s2s, so IP scheme is fitting our needs.

Hey wroot,

You are correct. If you are using the latest nightly build then clients can still connect to the server like the used to do it before. Let us know if you need some help.

Regards,

– Gato

I’'m still using 2.2.2, just preparing for 2.3.0 release Thanks. One job less to do