powered by Jive Software

Can a user be member in more than 1 group

Hello and thanks in advance for helping me.

I am in situation where I need to put a user in 2 groups

He is member of group A —> showing without problem

I add new group B —> make him the only user in it. — the group does not appear in the first place – it would only appear if I’'d add a new user to it who is not a member of another group.

I need to know if there is any solution that wil allow such scenario user added and showing in 2 groups.

Thanks

Hi,

Do you mean that Group B is not appearing on the client, while Group A is?

Does Group A only have this user as a member as well?

daryl

Sorry for late reply, was very ill.

Group A


Member1


Member2


Member3

No problems.

I create Group B - I add “Member1” to it also.

Group B is not showing.

I add Member 2 and 3 also to Group B - Still it would not show.

Group B will show only if I add a member to it who is not a member of any other group.

I need to be able to do that, can I ?

Thanks

Hey M.Hammad,

Which version of Openfire are you using? I tried to reproduce this case but it worked fine for me. Could you post the steps (including way groups are configured) you are doing so we can reproduce this case?

Thanks,

– Gato

I’‘m having the same problem using Openfire 3.3.0 and LDAP (more specifically, Active Directory). I used to have a bunch of Distribution groups to arrange everyone into departments, which worked perfectly. Then yesterday I deleted those groups and re-created them as Security groups so I could use them for setting different rights etc in Group Policy (something I should’'ve done to start with, really). I also made a Managers group for the heads of each department.

Now the groupings have messed up. Some of the department heads have remained in their original groups, while others have moved to the Managers group. None of them are in both groups at once. I’'ve tried disabling sharing the Managers group, but then the people in it just disappear rather than moving to other groups.

I’‘m a bit stuck now, and hoping there’'s a solution.

Hello Gato,

Thanks for taking the time and sorry for late reply.

Wildfire, Version: 3.2.2

=====================================

Group :- Directors

Contact List (Roster) Sharing :- Enable contact list group sharing

Enter contact list group name :- Directors

Share group with additional users :- YES – > The following groups: --> Then I select every group we have

Members of This Group :- Director1, Director2, Director3

======================================

Group :- New

Contact List (Roster) Sharing :- Enable contact list group sharing

Enter contact list group name :- New

Share group with additional users :- YES – > The following groups: --> Then I select every group we have

Members of This Group :- Director1

========================================

With above setup group “New” does not show for any user at all.

When I create any new user and add him/her to group “New” the group appears but listing only the new user not “Director1”

What I need is for Director1 to show in both groups.

Thanks again for your help, really.

M.Hammad

Hello,

Sorry for asking again, but it would be of great help if we can find a solution to that issue we are facing.

Thanks again

Hi,

it may help a lot if you could confirm that Openfire 3.3.0 works fine for you or if you still see this problem. I expect that you’'ll need to use the current version as backports for old versions are usually not done.

I tried this with 3.3.0 and would say that it works like one would expect it to work as Gato did already post.

LG

Hello,

Finally upgraded to latest version of openfire.

Now we have a progress, in the user properties it is showing as being a member of the two groups…

…still the user would show only in the latest group I’'d join him to.

The strange thing is it still shows as member of both groups in admin console but for clients it shows only in latest group it joined.

Thanks in advance.

Hello,

Please I need to know if there is a solution to that issue.

Thanks for your help.

Hi,

how can one reproduce this issue? For me this still looks to work fine.

If you have a group “G1” with users “user1” and “user2” and a group “G2” with user “user1” this works fine. Group “G2” will anyhow not be displayed in the roster of “user1” as it makes no sense that “user1” finds itself in its roster.

Maybe you can add some comments to this setup and what must be changed to reproduce your problem:

Openfire Configuration:

Group G1:

Members: user1,user2,user3

Share with: G2

Group G2:

Members: user1

Share with: G1

Clients A)

Spark - user1:

G1: user2

Spark - user2:

G1: user1

G2: user2

Spark - user3: offline

Clients B)

Spark - user1:

G1: user2, user3

Spark - user2:

G1: user1, user3

G2: user2

Spark - user3:

G1: user1, user2

G2: user1

LG

Hello IT2000 and thanks for taking the time to investigate that issue.

You have Jabber Server with whatever groups and users on it.

Login with any jabber client to that server with your own account

1- --> Create 2 groups “Group1” and “Group2”

2- --> Your roster will not change as the 2 groups are empty

3- --> Create 3 users : “user1”, “user2” and “user3”

4- --> Add them all to “Group1”

5- --> “Group1” will be added to your roster with the 3 users showing in it as off line.

6- --> edit “Group2” and add “user1” to it.

7- --> “user1” will disappear from “Group1” and “Group2” will be added to your roster with “user1” only in it.

8- --> Edit “Group2” and add “user2” and "user3"to it too.

9- --> “Group1” will disappear completely and “Group2” will still be showing with all 3 users in it.

What happened here is even though the 3 users are members of more than one group they still will only show for other users in the latest group they were added to.

I need the users to be showing in both groups in the same time.

Please let me know if following those steps will reproduce the problem at your setup or not.

Please let me know if I didn’'t explain my problem clearly maybe I can send snapshots of the process.

Thanks in advance

Hi,

I can reproduce this issue, interesting is that as soon as user1 gets online it will be displayed in all groups.

I did use the xmpp debug window and Openfire seems to do the right thing. Sending

<iq id="id" to="admin@host/spark2" type="set">
  <query xmlns="jabber:iq:roster">
    <item jid="user1@host" name="user1" subscription="to">
      <group>G2</group>
      <group>G1</group>
    </item>
  </query>
</iq>

should be fine if a user is in two groups but Spark has some problems to handle this. Adding user2 and user3 to Group2 causes Openfire to send similar packets to Spark.

So it could be a Smack/Spark bug, one should try to reproduce this with another client.

LG

Hello,

I tried it with JAJC and an online client “meebo” with exactly the same results.

Do you know of any client that does not suffer that bug so I ''d use instead ?

Thanks

Hi,

as Jivesoftware/IgniteRealtime did introduce the server side groups they may know best if these packets which are sent are really right and then decide whether this is a client or a server issue.

LG

Hi,

I did create JM-1063 so one can track this issue. Maybe it will be changed to a Spark issue but at least it’'s in the issue tracker.

LG