powered by Jive Software

Can i update from 4.0.2 to 4.1.3?

Hi Guys,

I have 4.0.2 openfire version and I want to update it. Can I update it to the latest one or I need to do setp by step 4.0.3 -> 4.0.4->4.1?

Thanks!

I think you should be fine. Of course, make a backup first. I plan to update my server from 4.0.4 to 4.1.3 tomorrow.

Grate, I’ll do tomorrow morning.

Thx!

Hi, the update went saccesfull, but I have some error in the group chat settings. I can handle it.

Hi, I did update from 4.0.3 to 4.1.3 and have the Problem too.

Firstly LDAP base DN was wrong. I did new LDAP setup but I can not add usergroups as a member of a room.

If I add a group “example” as a member I get message “Error removing the user/group. The room must have at least one owner.” Why remove if I adding it? And yes - I have a room owner.

If I add a group “example” as a owner, admin or outcasted it works and I get message “User/Group added successfully.”

How can i solve the Problem?

Hi, Thanks for the answer.

Same problem and messages but I can not resolve it yet. I’ll do a new ldap setup the and of the day.

Thanks!!

I think those problems are not related to the update process itself, so it is better to post it in a separate thread, so it will get more views (from LDAP users). I haven’t heard about LDAP not working correctly after the update. I suppose something has changed since 4.0 and it can’t work with old settings anymore. @speedy?

The problem with room members is not LDAP related i think and it was already reported and filed as [OF-1264] MUC: setting “Only login with registered nickname” breaks room user/group permissions UI - IgniteRealtime JIRA No fix yet.

OK, thank you for your message. I am going to restore last snapshot.

Odd.I’ll upgrade today to see if I can reproduce the issue. The only change with ldap is with LDAPS to allow tls 1.1 and 1.2 connections.

I upgraded without issue.