powered by Jive Software

Can Jive Support Other language

We Use Exodus,Can Jive Support Chinese!

This hasn’‘t been fully tested, but we don’'t anticipate any problems with language support. Please give it a try and let us know!

Regards,

Matt

Sorry, we do have a problem with tranditional Chinese (Big5). I was confused because we previously tried OpenIM and it worked fine.

Message was edited by:

loshsu

We Use Exodus with simplified chinese(GB) and info is mess(������),Can Jive Messenger support simplified chinese?

Can you provide some steps that we can use to try to reproduce this issue? Also, what database are you using?

Thanks,

Matt

i using jive 2 in redhut9 linux,database is mysql4.0,client is exodus on chinese.it’‘s no problem chat in english ,but Chating in simplified chinese is pane(������),Receiver can’'t see well chinese character. jive-messenger.xml in database as:

org.gjt.mm.mysql.Driver

jdbc:mysql://localhost/jivexmpp?characterEncoding=UTF-8

root

tomcat

5

5

1.0

true

true

O.S. is Windows 2000,database is SQL Server2000,Exodus can not create user.When we change database to mysql, it Work well,but not Support Chinese.

Could you check if there is more information in your error.log file? Also, are you using the latest CVS code (from today) and is your db updated with the latest db scripts?

BTW, I’'m not a MySQL expert but it seems that MySQL supports chinese (traditional & simplified). You need to set the correct character set in your jdbc URL. http://dev.mysql.com/doc/mysql/en/Charset-asian-sets.html

Regards,

– Gato

Thank you very much,now SQL Server2000 work well.but it do not support Chinese when I Use SQL Server2000,When I chat with Chinese,it show mess.In table jiveVCard,it do not show correct if there are Chinese.

thanks

Mysql4.1 supply chinese character.but i added to jive_messenger.xml as true and jdbc:mysql://localhost/jivexmp?characterEncoding=UTF-8

.Client can’'t login jive messenger after service reboot.

i see some error info in error.log:

2004.11.12 11:02:04 org.jivesoftware.messenger.user.spi.DbUserIDProvider.getUserID(DbUserIDProvider. java:110) Internal server error

java.sql.SQLException: General error message from server: “Illegal mix of collations (latin1_swedish_ci,IMPLICIT) and (utf8_general_ci,COERCIBLE) for operation ‘’=’’”

thanks.

Hey Tom,

I’'m not a MySQL expert but after doing a search in google it seems that the client character set is not the same as the one you used for creating the tables. Try using the same character set in both places.

If you are still having i18n problems, I’'d recommend posting to the MySQL forum since they will give you a better answer for sure.

Regards,

– Gato

MYSQL4.1 supplied is good in chinese.i see to convert sql result error in my jivemessenge. maybe jivemesseng have some bug in supplied other language.and My EXODUS login into jivesoftware.org that VCARD can’'t stored info in chinese.i am font of jivemessenge,i hope to do something in jive support other language that Give me a method when jive team is busy.

Hi Tom,

The SQLException is MySQL 4.1 complaining about incompatible character sets. In MySQL 4.1 each column can have it’'s own character set specified. At the table and database level there are default character set settings that control what value unspecified characters sets are defaulted to.

When you created the Messenger database and ran the database script the character set for all of the columns was set to latin1. Now that you’‘ve changed the character set you are specifying in the JDBC connection, MySQL is saying it doesn’'t know how to compare latin1 and utf8 strings.

So, if you are going to use utf8 in Messenger, you need to set the default character set of the Messenger database to utf8 to make sure that all of the tables and columns use utf8. You can do this when you create the database with this statement

CREATE DATABASE <database_name> DEFAULT CHARACTER SET utf8;

As for converting an existing database from latin1 to utf8, you’‘ll want to take Gato’'s recommendation and ask on the MySQL forums.

Regards,

Greg

greg ,now According to your guidance i can login jivemessenge:)because my client is exodus,it’‘s chinese chating is goods when i login to jivesoftware.org,but it’'s chinese chat is mess when i deploy jivemesseng 2.0 final service :(. why do?

thanks.

Hi,

Before you run the Messenger database script you need to create a database in MySQL. When you create the database, use this statement:

CREATE DATABASE <database_name> DEFAULT CHARACTER SET utf8;

where <database_name> is the name of the database you want to use. Then run the Messenger database script, run Messenger setup process, and finally set the MySQL connection URL the way you did above. This should get Messenger 2.0 working with MySQL 4.1 and UTF8.

Regards,

Greg

sorry,maybe i am not clearly description ,i do it is same with your direction in the morning.but exodus client received mess in chinese info.

Try using the tomorrow’'s nightly build which includes a fix for the problem you are having.

You should be fine with that.

Regards,

– Gato

thanks:)2.01 ver is beautiful.All kinds of function is right.

if you want to supply chinese in mysql,configure as:

1,create the database, use this statement:

CREATE DATABASE <database_name> DEFAULT CHARACTER SET utf8;

2.adding true and jdbc:mysql://localhost/jivexmpp?characterEncoding=UTF-8 to the section of your jive_messenger.xml.

life will go on.

thanks:)2.01 ver is beautiful.All kinds of function

is right.

if you want to supply chinese in mysql,configure as:

1,create the database, use this statement:

CREATE DATABASE <database_name> DEFAULT CHARACTER SET

utf8;

2.adding true

and

jdbc:mysql://localhost/jivexmpp?characterE

ncoding=UTF-8 to the section

of your jive_messenger.xml.

Glad it’‘s working for you now! Have you tested without using true? I’'d be curious to know if things worked without that flag. Also, how well do things work for Chinese with the embedded database?

Regards,

Matt

It works perfectly with the embedded database for Chinese(Big5). A great out-of-box experience.