powered by Jive Software

Can´t login

Hello!

I just have installed the openfire application.

I filled out the setup form, gave my login credentials and so on.

As I tried to login, a Password wrong dialog was shown to me.

I am using the openfire database, but I cant find a file to modify in /usr/share/openfire/embedded-db or in /var/lib/openfire/embedded-db

So how to change my password?

Did you try a openfire restart after you initial setup?

See JM-1537 for more details.

Yes I have restarted openfire several times.

I have tried to remove the setup variable in the openfire.xml, but the setup won´t start…

That’s strange, if I remove the

<setup>true</true>

part of my openfire.xml configuration, after a server restart it comes up with the setup. Maybe you could try to set it to:

<setup>false</setup>

What username do you use? It should be admin and not your email address. Which version do you use? I’m not sure, but I think in any older version there was a bug and the admin password was always set to “admin” too.

Hopefully that is helpfull.

I am using the openfire database, but I cant find a file to modify in /usr/share/openfire/embedded-db or in /var/lib/openfire/embedded-db

So how to change my password?

If you stop Openfire services there should be a file called openfire.script. This file should contain a line starting with:

INSERT INTO OFUSER VALUES('admin',NULL,'...','Administrator','admin@domain.lt', ...)

You should be able to change your password to “newPasswd”, if you change this line to:

INSERT INTO OFUSER VALUES('admin','newPasswd',NULL,'Administrator','admin@domain.lt', ...)

I have stopped openfire,but I have no database.

root@vserver1427:/var/lib/openfire/embedded-db# ls
openfire.lck openfire.log openfire.properties

root@vserver1427:/usr/share/openfire/embedded-db# ls
openfire.lck openfire.log openfire.properties

admin as password is not working too.

/edit: Maybe I should create a new database? Can u send me the content?

I thought you using the embedded database, maybe you use another DB server? Have you looked on the logs and saw some errors? Can you post your openfire.xml and some errors from the log? Do you have only problems to login to the admin console or also via a jabber client? Which OS do you use and how do you installed Openfire? Via the download packages here from this web site or via the OS package manager?

Yes, i am using the embedded database.

I have only tried to login to the admin client. I am using ubuntu and I have downloaded the package from the website.

/edit: Thats really weird. I have reinstalled openfire, configured it with a mysql database, but the same error is coming up. If I change the plain password in phpmyadmin nothing happens… (after a restart).

Now I have tried to reinstall it again, then the install script wanted the plain pw I entered in phpmyadmin. I typed it in and then I could set a new pw.

On the installation the pw works, but not in the script itself.

So, is your problem solved? In the case if not, please check the error.log and maybe others in the openfire/log directory. For resetting the admin password with mysql you can also look at Default admin password (and how to reset it). Do you think you found a repeatable bug?

I have tried to edit it manually (with setting the encryptet as NULL), but it don´t worked.

Now it works, thank you!