powered by Jive Software

Cannot change password via client - PSI/Exodus

I am running the last nightly build and I cannot seem to change the password via a client.

When I try to change the password via PSI or Exodus I get errors. Btw I am running on port 5223 (SSL) and port 5222 has been completely blocked.

Thanks!

Carlos,

I can’'t duplicate this issue with 2.1.0 final. Are you using LDAP by any chance? LDAP is read-only so changing passwords would fail. Changing passwords with the default user system seems to work great though.

Regards,

Matt

Matt,

LDAP is not being used. I get the same issue with Exodus and PSI, so I know it’‘s not a client. My setup as you know it’'s a new DB that was created with 2.1.0 beta 1. Will this be the issue? I am pasting a copy of the XML code here, I was trying to change my current password to 1234. I am not the only one experiencing the problem, everyone else in my server experiences it as well.

cserpa

1234

Matt,

I found the problem. The server will not allow me to change the password when “Inband Account Registration” is disabled, but won’'t when enabled. This can be a problem for companies that want to keep employees from creating new users and also be able to give the access to employees to change the passwords.

Try it on your side and let me know what you think!

Carlos,

Ok, I’'m filing this as a bug. I think the solution is to have a separate option on whether users should be allowed to change their password or not.

Thanks,

Matt

Hi

I have the same problem and I would propose that changing passwords by the user should allways be possible as a default setting. Changing the vCard entries is possible at any time, changing the password should be, too.

Has Anyone found a good workaround for this? I want to disable open registration, but I would like for users to change their own passwords. I was thinking possibly revoking insert priv to the Mysql Database, but what tables do I need to revoke inserts to make it so a new account cannot be created?