Cannot install plugin for Openfire

Hi, I’m a new user for Openfire. I was install Openfire 3.5.1 on Windows Server 2003.

I found that I can’t install any of the plugin. Whether or not choose to use embedded database that came with Openfire

or use the external database which is MySQL. I’ve tried to uninstall, reinstall the Openfire and its plugin, and it still won’t works.

Example “IM Gateway”. The 1st time I logged in to the Openfire admin page with the “IM Gateway” plugin installed, the “Gateway”

option apprear on the admin page. But if I refresh the page or click on other link, then the “Gateway” option disappear forever and

the “Gateway” option will never display again.

When the “Gateway” option apprear on the admin page, the registration link is not working. It just display “The page cannot be found”

error message when click on it.

Every plugins that I downloaded from the Openfire website are all behave the same issue. Why ??

I’m sure that I was using the the latest version of the plugin downloaded from the Openfire website.

Can anyone please help ??? Thank you very much.

Are there any errors in the logs? Have you tried to manually download the plugin from the webpage, and install it via drag and drop in the plugins folder of openfire? Did you check permissions of the openfire folder?