Cannot log in after upgrading to 3.5

I just upgraded to Openfire 3.5 yesterday and everything was fine. Today we cannot log in, we are getting invalid username and password. I tried to log into the admin console and I am getting Login Failed: make sure your username and password are correct and that you’re an admin or moderator.

I am not sure what happened overnight but now we cannot get in and I cannot get to the admin console to check it out.

Hi superflyer77,

Can you look at the log files and see if there are any clues there? Found in logs/ on the filesystem…


I think that I may have figured it out. Yesterday we demoted an old domain controller and I think that Openfire was pointing at that one. Now since it is not a domain controller any more it cannot help out.

I rolled the server back from an image and I am getting the same issue so I am sure that it is not the version of Openfire now and I think that it is the server that it is pointing to to get the information from AD. I just need to figure out a way to change that from the outside since I cannot log into Openfire to change it.

OK I figured it out.

I had to change the setup from true to false in the openfire.xml file in the conf folder. Then I ran the exe to do the install again. The best part was that it remembered all my settings and I was right it was pointing to the wrong DC server. I changed that to the new one and everything is good now.

Thanks for the tip on the log files that is where I got the idea that it was pointing to the wrong one.