powered by Jive Software

Cannot log in to Admin Console

Hello All,

I am new to the forums and really need some help with setting up Wildfire jabber server. I used the installation guide to do a default install on a kubuntu server version 6.06. I have wildfire started but I cannot login to the Wildfire Administration Console at http://127.0.0.1:9090/login.jsp. I tried using admin for username and admin for password. I am not using an external database. How can I reset the administration console password so I can login and finish setting up wildfire? Do I need to reset the admin password? Any help would be greatly appreciated.

Thank you,

Scotty

If you are using the embedded HSQL db, I would start here for some hints …

http://www.jivesoftware.org/builds/wildfire/docs/latest/documentation/database.h tml#hsql

I have not used wildfire with HSQL, but it sounds like you may have had to specify the location of the db during wildfire installation. You might try connecting directly to the HSQL db and updating the jiveUser table something like the following:

UPDATE jiveUser SET PASSWORD = ‘‘admin’’ where username=’‘admin’’;

COMMIT;

-Chip

Hi Scotty,

if you are using the embedded database it’'s more easy to shutdown Wildfire and edit embedded-db/wildfire.script and change the line

INSERT INTO JIVEUSER VALUES(’‘admin’’, …

to

INSERT INTO jiveUser (username, password, name, email, creationDate, modificationDate)

VALUES (''admin'', ''admin'', ''Administrator'', ''admin@example.com'', ''0'', ''0'');

For every other database: Use SQL to change it, like

DELETE FORM jiveUser WHERE username=’‘admin’’;

INSERT INTO jiveUser (username, password, name, email, creationDate, modificationDate)

VALUES (''admin'', ''admin'', ''Administrator'', ''admin@example.com'', ''0'', ''0'');

commit;

If you have already registered a chat account / JID and now it’'s password you may skip the SQL stuff and change conf/wildfire.xml and add there your JID into authorizedJID, it should look like:

<jive>
<admin>
<authorizedJIDs>scotty@example.com</authorizedJIDs>
</admin>
... the other configuration stuff
</jive>

LG

Hello All,

I would like to say thank you to the users who replied to my question and I am sure that this will be helpful for other users in the future. I did not have time to continue working with this project after learning that it does not support virtual hosts currently. I may revisit this software in the future. My employer is still thinking of using this software but for my personal webhosting project I need the virtual hosting feature. This is a very nice looking software and it has some great features. I hope the development continues with this product. I am not sure if the question needs to be marked answered. Again I really appreciate the time that you all have taken to look at my question and reply.

Thank you again,

Scotty

Hi Scotty,

as long as you did ask just one question you’'ll always notice the “You have 1 unresolved question(s). Your Questions” text. So you can always visit the question and track the progress of resolution. If you have 20 unresolved questions this may become time-consuming.

The forum allows you to mark answers to your question as helpful or correct, if you use this feature other users with similar questions may find the right answer much faster, especially if it is a long thread.

And as soon as you have marked your question as answered one is sure that you got the help you wanted.

LG